Bug 1513199 - Rebase on upstream 1.1.18
Summary: Rebase on upstream 1.1.18
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker
Version: 6.10
Hardware: All
OS: All
high
medium
Target Milestone: rc
: 6.10
Assignee: Ken Gaillot
QA Contact: cluster-qe@redhat.com
Steven J. Levine
URL:
Whiteboard:
: 1561365 (view as bug list)
Depends On:
Blocks: 1493755
TreeView+ depends on / blocked
 
Reported: 2017-11-15 00:09 UTC by Ken Gaillot
Modified: 2018-06-19 05:18 UTC (History)
9 users (show)

Fixed In Version: pacemaker-1.1.18-1.el6
Doc Type: Release Note
Doc Text:
_pacemaker_ rebased to version 1.1.18 The _pacemaker_ packages have been upgraded to upstream version 1.1.18, which includes the following behavioral difference: Pacemaker now probes virtual machines launched with a Pacemaker Remote connection ("guest nodes"), just as it probes any node that joins the cluster. This allows Pacemaker to catch services that were mistakenly started at boot or by hand, and to refresh its knowledge after a resource clean-up. As such, it is important in order to be able to avoid having a service running in conflicting locations. However, these probes must be executed and the results processed before any resources can be started on the guest node. This can result in a noticeable increase in start-up time. Also, if users were previously relying on the probes not being done, the probes may fail (for example, if the relevant software isn't installed on the guest). These effects can be avoided in cases where it is not possible for certain resources to run on the guest nodes. Usually there will already be -INFINITY location constraints enforcing that. Users can add `resource-discovery=never` to the location constraint options to tell pacemaker not to probe that resource on the guest nodes. (This should not be done for any resource that can run on the guest.)
Clone Of:
Environment:
Last Closed: 2018-06-19 05:17:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1894 None None None 2018-06-19 05:18:25 UTC
Red Hat Knowledge Base (Solution) 3227151 None None None 2018-03-28 20:28:52 UTC

Description Ken Gaillot 2017-11-15 00:09:12 UTC
Even though RHEL 6 has limited development now, a rebase makes sense for Pacemaker because:

* 1.1.18 will be the last actively developed upstream release to support CMAN

* RHEL 7.5 will be based on 1.1.18, and having 6.10 on the same version would be easier for support and documentation to work with

* 1.1.18 includes the fixes for Bug 1388102, Bug 1427643, and Bug 1500510. Rebasing would be much simpler than backporting these fixes against the current RHEL 6.9 code.

* 1.1.18 includes many fixes related to the Pacemaker Remote use case, especially when used within a Docker container as part of Pacemaker's new "bundle" feature. The rebase would give us the option of supporting a RHEL 7 Pacemaker cluster running RHEL 6 containers, which I suspect will be a common use case for running legacy applications that can't immediately be ported to RHEL 7.

Comment 7 Ken Gaillot 2018-03-28 20:28:52 UTC
*** Bug 1561365 has been marked as a duplicate of this bug. ***

Comment 8 Patrik Hagara 2018-04-25 07:30:14 UTC
test suite found no regressions, marking verified

Comment 11 errata-xmlrpc 2018-06-19 05:17:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1894


Note You need to log in before you can comment on or make changes to this bug.