Bug 151328 - Up2date generates an error when a user's password begins with an asterisk
Up2date generates an error when a user's password begins with an asterisk
Status: CLOSED DUPLICATE of bug 155379
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Max Spevack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 18:29 EST by Steve Conklin
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 14:42:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Conklin 2005-03-16 18:29:46 EST
Description of problem:

 When a user's password begins with an asterisk, the up2date utility (both
graphical and text) returns with an error that the password cannot be all asterisks.

Version-Release number of selected component (if applicable):

Confirmed for:
up2date-4.2.57-2
and
up2date-4.4.5-1

How reproducible:
every time

Steps to Reproduce:
1. Attempt to enter a password that starts with an asterisk
2. Observe the result
3.
  
Actual results:

Error Message:
   password can not be all asterisks '*'
Error Class Code: 15
Error Class Info: The username contains invalid characters.
Explanation:
    An error has occurred while processing your request.  [...]

Expected results:
Should work

Additional info:
As a side note, the RHN web site DOES allow a password of all asterisks.
Comment 3 Adrian Likins 2005-04-19 14:14:59 EDT
Looks to be just reporting the error message the server is
sending back, so opening a bug against the server code. 

Keeping this bug open till the exception in the cli is handled
correctly.
Comment 4 Debbie McGrath 2005-05-05 10:32:29 EDT
Adding this to the RHN Update Agent for RHEL 3 U6 tracking bug - just to make
sure we don't lose it while making sure it's really only server side.
Comment 5 Adrian Likins 2005-05-17 14:42:12 EDT

*** This bug has been marked as a duplicate of 155379 ***

Note You need to log in before you can comment on or make changes to this bug.