Bug 151330 - Amarok scrobbler support broken
Amarok scrobbler support broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 18:39 EST by Peter Lawler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 04:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lawler 2005-03-16 18:39:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Scrobbler requirements are (iirc):
Track must be at least 30 seconds long
Track must play at least 50%

This build seems to submit immediately upon start of playback.

Version-Release number of selected component (if applicable):
amarok.i386 0:1.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Start amarok
2. Configure for scrobbler submission
3. Play track

  

Actual Results:  Indicator says track is submitted immediately

Expected Results:  Amarok should wait for at least 30 seconds, then for at least 50% of playback before submission.

Additional info:

Could this be related to bug 151329?
Comment 1 Aurelien Bompard 2005-03-17 04:14:47 EST
The amarok devlopers are aware of the scrobbler specs :
http://bugs.kde.org/show_bug.cgi?id=94417
The limit seems to be 240 seconds, not 30.
Comment 2 Peter Lawler 2005-03-17 16:40:08 EST
http://www.audioscrobbler.com/development/protocol.php is the full protocol
spec. I was getting 30 seconds confused with minimum track length for submission.

Either way, amarok should not immediately submit data.
Comment 3 Peter Lawler 2005-03-17 17:22:25 EST
Work around for 151329 fixes this issue.

Note You need to log in before you can comment on or make changes to this bug.