Bug 1513414 - list of volumes is synchronized in Tendrl but not in Grafan
Summary: list of volumes is synchronized in Tendrl but not in Grafan
Keywords:
Status: CLOSED DUPLICATE of bug 1516672
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 11:27 UTC by Martin Kudlej
Modified: 2017-11-23 20:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 20:47:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1513046 None None None Never

Internal Links: 1513046

Description Martin Kudlej 2017-11-15 11:27:58 UTC
Description of problem:
During of verifying of bug 1509282 I've hit this issue.

I've seen that collectd has not been down but I'm not sure that this is the reason of issue. So Tendrl was not able to consume Gluster event about deleting the volume. So I've still seen deleted volume in Tendrl UI and Grafana.

But after some time I see deleted volume just in Grafana and not in Tendrl. I expect that there was synchronization of Tendrl with Gluster cluster state. This has not happen for Grafana. 

Probably this is connected with bug 1513046.

Version-Release number of selected component (if applicable):
etcd-3.2.7-1.el7.x86_64
glusterfs-3.8.4-52.el7_4.x86_64
glusterfs-3.8.4-52.el7rhgs.x86_64
glusterfs-api-3.8.4-52.el7rhgs.x86_64
glusterfs-cli-3.8.4-52.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-52.el7_4.x86_64
glusterfs-client-xlators-3.8.4-52.el7rhgs.x86_64
glusterfs-events-3.8.4-52.el7rhgs.x86_64
glusterfs-fuse-3.8.4-52.el7_4.x86_64
glusterfs-fuse-3.8.4-52.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-52.el7rhgs.x86_64
glusterfs-libs-3.8.4-52.el7_4.x86_64
glusterfs-libs-3.8.4-52.el7rhgs.x86_64
glusterfs-rdma-3.8.4-52.el7rhgs.x86_64
glusterfs-server-3.8.4-52.el7rhgs.x86_64
gluster-nagios-addons-0.2.10-2.el7rhgs.x86_64
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
libvirt-daemon-driver-storage-gluster-3.2.0-14.el7_4.3.x86_64
python-etcd-0.4.5-1.el7rhgs.noarch
python-gluster-3.8.4-52.el7rhgs.noarch
rubygem-etcd-0.3.0-1.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-collectd-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-gluster-integration-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch

How reproducible and Steps to Reproduce:
Hard to say, but it can be reproduced by stop of collectd before deleting volume and start it again after some time.

Actual results:
If Tendrl miss gluster event about deleting of volume then volume stays in Grafana but not in Tendrl UI(because of synchronization with cluster).

Expected results:
Synchronization with cluster should done also for Grafana and not just for Tendrl UI.

Comment 3 Nishanth Thomas 2017-11-15 12:24:52 UTC
We need a clear reproducer to debug and fix this issue

Comment 4 gowtham 2017-11-17 13:22:47 UTC
Please check it is behave like, deleted but it will come again in grafana.

Comment 5 Martin Kudlej 2017-11-23 20:47:04 UTC

*** This bug has been marked as a duplicate of bug 1516672 ***


Note You need to log in before you can comment on or make changes to this bug.