Bug 1513447 - QEMU image file locking (libvirt)
Summary: QEMU image file locking (libvirt)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 27
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1529035 (view as bug list)
Depends On: 1378242
Blocks: 1518517
TreeView+ depends on / blocked
 
Reported: 2017-11-15 12:23 UTC by Oyvind Albrigtsen
Modified: 2018-01-30 19:31 UTC (History)
30 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1378242
Environment:
Last Closed: 2018-01-30 19:31:18 UTC
Type: Bug


Attachments (Terms of Use)

Comment 1 Daniel Berrangé 2017-11-16 13:01:08 UTC
We'll need this patch series in F27, once it is acked:

https://www.redhat.com/archives/libvir-list/2017-November/msg00617.html

Comment 2 Peter Krempa 2017-11-24 17:05:25 UTC
The series was pushed:

28907b0043 qemu: command: Mark <shared/> disks as such in qemu
860a3c4bea qemu: caps: Add capability for 'share-rw' disk option
2b41c86294 qemu: Disallow pivot of shared disks to unsupported storage
9b2fbfa6f6 qemu: snapshot: Disallow snapshot of unsupported shared disks
3b03a27cd0 qemu: domain: Reject shared disk access if backing format does not support it
1fc3cd8731 qemu: block: Add function to check if storage source allows concurrent access
85b0e2f126 qemu: domain: Refactor domain device validation function
ab948b6299 qemu: domain: Move video device validation into separate function
a6936ec098 qemu: domain: Move hostdev validation into separate function
577ccd07c3 qemu: domain: Despaghettify qemuDomainDeviceDefValidate
8ffdeed455 qemu: Move snapshot disk validation functions into one

Comment 3 bialekr 2017-11-29 08:00:09 UTC
Any idea when the patch will be approximately released for F27?

Comment 4 Cole Robinson 2017-11-29 15:09:35 UTC
(In reply to bialekr from comment #3)
> Any idea when the patch will be approximately released for F27?

I will do a build this week

Comment 5 Fedora Update System 2017-12-04 18:12:58 UTC
libvirt-3.7.0-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b16cdbdc34

Comment 6 Fedora Update System 2017-12-10 00:29:31 UTC
libvirt-3.7.0-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b16cdbdc34

Comment 7 Fedora Update System 2017-12-12 11:22:55 UTC
libvirt-3.7.0-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Richard W.M. Jones 2017-12-26 10:12:38 UTC
*** Bug 1529035 has been marked as a duplicate of this bug. ***

Comment 9 Tom Horsley 2017-12-26 23:30:56 UTC
My bug 1529035 was marked as a duplicate of this, but I have libvirt-3.7.0-3.fc27 on my system and still have a problem with guestmount --ro no longer working in fedora 27 on a live VMs disk image (more details in bug 1529035). Is this really the same as my bug?

Comment 10 Cole Robinson 2018-01-30 19:30:48 UTC
Tom, if you're still hitting issues, please reopen your old bug or file a new one


Note You need to log in before you can comment on or make changes to this bug.