Bug 151345 - system-config-printer setup of networked lpd server fails
system-config-printer setup of networked lpd server fails
Status: CLOSED DUPLICATE of bug 151475
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 22:37 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 09:11:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2005-03-16 22:37:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Using the command line system-config-printer, I set up my LPD print server networked Samsung Laser ML-1750 printer.  All looked fine until I tried a test page print.  No printout, and the error message "Unable to reserve port. Permission denied" appeared in the printer status line.

The port used was server name = 192.168.1.102, printer name L2

This same setup works in FC3 and a number of other distributions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run system-config-printer 1.
set up LPD server networked printer 2.
print a test page 3.
  

Actual Results:  No printout.  Printer status says "Unable to reserve port. Permission denied."

Expected Results:  Test page should have printed.

Additional info:
Comment 1 Tim Waugh 2005-03-17 04:09:11 EST
Does this happen if you try again now? (It might be different if you have
rebooted since this report.)

If it still happens, please show me the output of 'netstat -tlp' as root.
Comment 2 Gerry Tool 2005-03-17 09:02:57 EST
Still happens.  Your message prompted me to remember the firewall problem with
FC3, so I checked with/without the firewall enabled - same result.
Here is the result:
[root@gstpc ~]# netstat -tlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address            
State       PID/Program name
tcp        0      0 *:32768                     *:*                        
LISTEN      2184/rpc.statd
tcp        0      0 *:sunrpc                    *:*                        
LISTEN      2166/portmap
tcp        0      0 gstpc.localdomain:ipp       *:*                        
LISTEN      2387/cupsd
tcp        0      0 gstpc.localdomain:5335      *:*                        
LISTEN      2369/mDNSResponder
tcp        0      0 gstpc.localdomain:smtp      *:*                        
LISTEN      2495/sendmail: acce
tcp        0      0 *:ssh                       *:*                        
LISTEN      2449/sshd

I have been unable to update a few packages due to dependencies:

[root@gstpc ~]# yum update
Setting up Update Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:04
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libwnck.i386 0:2.10.0-1 set to be updated
---> Package pilot-link.i386 1:0.12.0-0.pre2.0 set to be updated
---> Package usermode-gtk.i386 0:1.79-2 set to be updated
---> Package usermode.i386 0:1.79-2 set to be updated
---> Package gok.i386 0:1.0.2-1 set to be updated
---> Package kdepim.i386 6:3.4.0-0.rc1.4 set to be updated
---> Package kdepim-devel.i386 6:3.4.0-0.rc1.4 set to be updated
---> Package gnome-panel.i386 0:2.10.0-1 set to be updated
---> Package gnome-system-monitor.i386 0:2.10.0-1 set to be updated
--> Running transaction check
--> Processing Dependency: libwnck-1.so.4 for package: gnome-applets
--> Processing Dependency: libpisock.so.8 for package: gnome-pilot
--> Finished Dependency Resolution
Error: Missing Dependency: libwnck-1.so.4 is needed by package gnome-applets
Error: Missing Dependency: libpisock.so.8 is needed by package gnome-pilot
Comment 3 Tim Waugh 2005-03-18 09:11:29 EST

*** This bug has been marked as a duplicate of 151475 ***

Note You need to log in before you can comment on or make changes to this bug.