Bug 1513464 - In conntrack SNAT Vpn to dpn maps fails to update when a subnet is added/removed
Summary: In conntrack SNAT Vpn to dpn maps fails to update when a subnet is added/removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Aswin Suryanarayanan
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 13:10 UTC by Aswin Suryanarayanan
Modified: 2018-10-18 07:22 UTC (History)
2 users (show)

Fixed In Version: opendaylight-6.2.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight gerrit 65124 None None None 2017-11-15 13:12:07 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:40:23 UTC

Description Aswin Suryanarayanan 2017-11-15 13:10:11 UTC
Description of problem:
In conntrack SNAT Vpn to dpn maps fails to update when a subnet is added/removed

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1)Create a external router and set as the router as g/w
2)Add subnets to the router.
3)The subnet router port needs to be added to vpn to Dpn map.

Actual results:
The router port is not added.

Expected results:
The router port should be added.

Comment 1 Aswin Suryanarayanan 2017-11-15 13:16:04 UTC
https://code.engineering.redhat.com/gerrit/#/c/122748/

Comment 8 Itzik Brown 2018-03-22 08:38:02 UTC
Verified with:
opendaylight-8.0.0-2.el7ost.noarch

1. Created an internal network and an external network
2. Launched an instance connected to the internal network
3. Created a router and add the gateway info
4. Verified the NAPT switch is not on the same node as the instance
5. Added the internal interface to the router
6. Checked connectivity from the instance to an external IP

Comment 10 errata-xmlrpc 2018-06-27 13:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.