Bug 1513477 - Check of lock in periodic task is incorrect
Summary: Check of lock in periodic task is incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michel Peterson
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 13:57 UTC by Michel Peterson
Modified: 2018-10-18 07:19 UTC (History)
3 users (show)

Fixed In Version: python-networking-odl-12.0.1-0.20180228140714.8733cf6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1731893 None None None 2017-11-15 13:58:00 UTC
OpenStack gerrit 519384 None master: MERGED networking-odl: Fix on PeriodicTask locking mechanism (I4288274bced051236e163f5786b91fe408f8453d) 2018-03-29 16:04:38 UTC
OpenStack gerrit 520572 None stable/pike: MERGED networking-odl: Fix on PeriodicTask locking mechanism (I4288274bced051236e163f5786b91fe408f8453d) 2018-03-29 16:04:31 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:40:23 UTC

Description Michel Peterson 2017-11-15 13:57:33 UTC
Description of problem:

A refactor patch [1] introduced an error in the logic of the `execute_ops` of `PeriodicTask` [2] (L100) where it no longer tests for a `False` condition but instead for a `True`.

[1] https://review.openstack.org/#/c/500584/
[2] https://review.openstack.org/#/c/500584/13/networking_odl/journal/periodic_task.py


Version-Release number of selected component (if applicable): n/a


How reproducible: 100%


Steps to Reproduce:
1. Run neutron
2. Look at the logs


Actual results:

The periodic task is locked but at the same time it's logged that the task is locked and no operations are run. Next iteration operations will be run and then unlocked.

Expected results:

The periodic task is locked, operations are executed and then unlocked.
Additional info:

Comment 2 Michel Peterson 2017-11-22 13:05:44 UTC
Fix merged in master and stable/pike

Comment 9 Mike Kolesnik 2018-04-01 12:28:13 UTC
I checked it on Itzik's deployment, this is fine now as the maintenance task is executing normally as it should by it's defined interval.

Comment 11 errata-xmlrpc 2018-06-27 13:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.