Bug 1513497 - FQDN hieradata is hardcoded.
Summary: FQDN hieradata is hardcoded.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z3
: 12.0 (Pike)
Assignee: Emilien Macchi
QA Contact: Pavan
URL:
Whiteboard:
Keywords: Triaged, ZStream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 14:23 UTC by Juan Antonio Osorio
Modified: 2018-08-09 14:54 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-07-25 14:19:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 520082 None None None 2017-11-15 14:23 UTC
Launchpad 1732457 None None None 2017-11-15 14:23 UTC

Description Juan Antonio Osorio 2017-11-15 14:23:11 UTC
Description of problem:

FQDN hieradata is hardcoded.

With the move to composable networks, most of the network-related bits are now dynamically generated with jinja. The only exception seems to be the FQDN hieradata keys, which still are hardcoded.

Which means that nay service that uses the FQDN hiera keys depending on the network will fail to do so on a custom network.

Version-Release number of selected component (if applicable):
OSP12

How reproducible:
100%

Steps to Reproduce:
1. Deploy the overcloud with a custom network (by modifying roles_data.yaml and network_data.yaml)
2. verify the fqdn_* hiera keys.

Actual results:
fqdn_* hiera keys are not generated for the custom network(s)

Expected results:
They should be generated.

Additional info:

Comment 3 Harry Rybacki 2018-01-30 16:28:25 UTC
Moving this bug to post as upstream reviews have all merged and LP#1732457 shows fix-released. Will determine if change slipped into a zstream release at some point and update bug accordingly.

Comment 11 Juan Antonio Osorio 2018-07-25 14:19:24 UTC
This is already working in newer releases.


Note You need to log in before you can comment on or make changes to this bug.