Bug 1513565 - post-deployment validations return false positive SUCCESS output
Summary: post-deployment validations return false positive SUCCESS output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M1
: 15.0 (Stein)
Assignee: Florian Fuchs
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 15:46 UTC by Ola Pavlenko
Modified: 2019-09-26 10:44 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-10.4.1-0.20190621220403.673148d.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:15:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 500067 0 None None None 2018-08-07 11:31:15 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:16:08 UTC

Description Ola Pavlenko 2017-11-15 15:46:12 UTC
Description of problem:
Running "Check the status of the pacemaker cluster" validation when no overcloud was deployed returns a false positive Success output.

Version-Release number of selected component (if applicable):

openstack-tripleo-validations-5.1.2-1.el7ost.noarch
openstack-tripleo-ui-1.2.1-1.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.before deploying an overcloud run "Check the status of the pacemaker cluster" validation
2.
3.

Actual results:
Succeed 

Expected results:
Failed. 

Additional info:

Comment 1 Ola Pavlenko 2017-11-15 15:51:20 UTC
Same behavior for all post-deployment validations. 

from cli:
$ ansible-playbook  /usr/share/openstack-tripleo-validations/validations/pacemaker-status.yaml
 [WARNING]: Could not match supplied host pattern, ignoring: all

 [WARNING]: provided hosts list is empty, only localhost is available

 [WARNING]: Could not match supplied host pattern, ignoring: controller


PLAY [controller] *************************************************************************************************************************************************************************************************
skipping: no hosts matched

PLAY RECAP ********************************************************************************************************************************************************************************************************

Comment 2 Gaël Chamoulaud 2017-11-22 13:09:58 UTC
(In reply to Ola Pavlenko from comment #1)
> Same behavior for all post-deployment validations. 
> 
> from cli:
> $ ansible-playbook 
> /usr/share/openstack-tripleo-validations/validations/pacemaker-status.yaml
>  [WARNING]: Could not match supplied host pattern, ignoring: all
> 
>  [WARNING]: provided hosts list is empty, only localhost is available
> 
>  [WARNING]: Could not match supplied host pattern, ignoring: controller
> 
> 
> PLAY [controller]
> *****************************************************************************
> *****************************************************************************
> ***************************************
> skipping: no hosts matched
> 
> PLAY RECAP
> *****************************************************************************
> *****************************************************************************
> **********************************************

Do you have the same error including inventory script to your cli?

ansible-playbook -i $(which tripleo-ansible-inventory) /usr/share/openstack-tripleo-validations/validations/pacemaker-status.yaml

Comment 13 errata-xmlrpc 2019-09-21 11:15:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.