Bug 1513594 - man pages in unexpected package
Summary: man pages in unexpected package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redis
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 16:24 UTC by Carl George
Modified: 2017-12-10 05:08 UTC (History)
4 users (show)

Fixed In Version: redis-4.0.5-1.fc26 redis-4.0.4-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-09 22:27:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Carl George 2017-11-15 16:24:11 UTC
Description of problem:
When you install redis, there are no man pages available.  They were moved to the -docs subpackage.  This is a poor user experience.

Version-Release number of selected component (if applicable):
redis-4.0.2-1.fc28

How reproducible:
always

Steps to Reproduce:
1. dnf install redis
2. man redis-cli

Actual results:
No manual entry for redis-cli

Expected results:
show redis-cli man page

Comment 1 Nathan Scott 2017-11-15 21:20:02 UTC
Hi Carl,

As of redis-4.x we've begun incorporating significant amount of additional documentation from the upstream Redis developers.  This aims to improve the user experience overall.

All of the documentation is available in redis-doc, as you found.

In this regard, we're following the guidelines outlined here:
https://fedoraproject.org/wiki/Packaging:Guidelines#Documentation

" ... if there's a lot of documentation, consider putting it into a subpackage. In this case, it is recommended to use *-doc as the subpackage name."

This technique is commonly used in other packages, such as git-core-doc.

It has the advantage of keeping the size of the core redis package smaller too, which is appreciated by people building Redis containers.

$ rpm -qi redis | grep Size
Size        : 1571517
$ rpm -qi redis-doc | grep Size
Size        : 2856236

cheers.

Comment 2 Carl George 2017-11-16 22:20:30 UTC
I have read those guidelines and understand the purpose of the -doc subpackage.  However, those guidelines make no mention of man pages.  Personally, my expectation is that if a command is available, I should have the respective man page available.  I'm fine with larger documentation being in an optional -doc subpackage, but not man pages.  Anecdotally, everyone I've asked about this feels the same way, so at the very least I'm not the only one who feels this way.

Likewise, I disagree with how git is doing it, but most people won't notice it there because the top level git package pulls in git-core and git-core-doc as dependencies.

I appreciate the intent of making the package smaller, but I believe the point is moot because when size is a concern (containers), `tsflags=nodocs` will be set.  This means that the 8.9KB of man pages wouldn't be installed anyways regardless of which package they are in.

Please reconsider moving the man pages back to the main package.

Comment 3 Nathan Scott 2017-11-30 23:14:55 UTC
Re-opening, as another request for this has arrived and the man pages are not immense in the big scheme of things - reverting this change in the 4.0.4 update.

Thanks Carl.

Comment 4 Fedora Update System 2017-12-01 00:39:26 UTC
redis-4.0.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60109c0576

Comment 5 Fedora Update System 2017-12-01 00:39:46 UTC
redis-4.0.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9c179d4157

Comment 6 Fedora Update System 2017-12-02 08:18:22 UTC
redis-4.0.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9c179d4157

Comment 7 Fedora Update System 2017-12-02 22:39:27 UTC
redis-4.0.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-60109c0576

Comment 8 Fedora Update System 2017-12-02 23:09:21 UTC
redis-4.0.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ff072b2156

Comment 9 Fedora Update System 2017-12-02 23:09:45 UTC
redis-4.0.5-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ef68f3f89

Comment 10 Fedora Update System 2017-12-03 20:50:55 UTC
redis-4.0.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7ef68f3f89

Comment 11 Fedora Update System 2017-12-03 22:46:55 UTC
redis-4.0.5-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ff072b2156

Comment 12 Fedora Update System 2017-12-07 23:52:52 UTC
redis-4.0.6-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-57468d2c9b

Comment 13 Fedora Update System 2017-12-09 05:47:25 UTC
redis-4.0.6-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-57468d2c9b

Comment 14 Fedora Update System 2017-12-09 22:27:21 UTC
redis-4.0.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-12-10 05:08:17 UTC
redis-4.0.4-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.