Bug 1513641 - pyotherside package requires old version of qt5-qtbase
Summary: pyotherside package requires old version of qt5-qtbase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyotherside
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 17:48 UTC by Paul Nickerson
Modified: 2017-11-22 02:29 UTC (History)
3 users (show)

Fixed In Version: pyotherside-1.5.3-2.fc27 pyotherside-1.5.3-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 02:29:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Nickerson 2017-11-15 17:48:25 UTC
Description of problem: I am unable to update pyotherside using dnf, as it requires a version of qt5-qtbase that is older than the version I have installed.


Version-Release number of selected component (if applicable): 1.5.3-1.fc27


How reproducible: Every time I run "dnf update"


Steps to Reproduce:
1. dnf update


Actual results:
 Problem: cannot install both qt5-qtbase-5.9.1-9.fc27.x86_64 and qt5-qtbase-5.9.2-4.fc27.x86_64
  - package pyotherside-1.5.3-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.1, but none of the providers can be installed
  - cannot install the best update candidate for package qt5-qtbase-5.9.2-4.fc27.x86_64
  - cannot install the best update candidate for package pyotherside-1.5.1-4.fc27.x86_64
===================================================================================================================================
 Package                          Arch                        Version                           Repository                    Size
===================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                       x86_64                      5.9.1-9.fc27                      fedora                       3.4 M
Skipping packages with broken dependencies:
 pyotherside                      x86_64                      1.5.3-1.fc27                      updates                       87 k


Expected results:
pyotherside is updated


Additional info:
I currently have pyotherside-1.5.1-4.fc27.x86_64 and qt5-qtbase-5.9.2-4.fc27.x86_64 installed. Both are from the "updates" repository for Fedora 27 (Workstation Edition). Here is the package dependency I see:

$ dnf repoquery --requires pyotherside-1.5.3-1.fc27.x86_64 | grep qt5-qtbase
qt5-qtbase(x86-64) = 5.9.1

Currently, 5.9.2-4.fc27 is the latest version of qt5-qtbase available in the updates repo.

Comment 1 Fedora Update System 2017-11-16 07:55:10 UTC
pyotherside-1.5.3-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-86e4715436

Comment 2 Fedora Update System 2017-11-16 07:55:17 UTC
pyotherside-1.5.3-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-633ad655e6

Comment 3 Fedora Update System 2017-11-17 16:42:34 UTC
pyotherside-1.5.3-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2017-11-18 01:44:29 UTC
pyotherside-1.5.3-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-633ad655e6

Comment 5 Fedora Update System 2017-11-22 02:29:02 UTC
pyotherside-1.5.3-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.