Bug 151375 - RHEL3: top has screen errors on large smp machines
RHEL3: top has screen errors on large smp machines
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procps (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 07:52 EST by Karel Zak
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 04:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2005-03-17 07:52:11 EST
+++ This bug was initially created as a clone of Bug #149616 +++

Description of problem:
On our 32 processor systems (both x86 and ia64), when "top" is used to display
seperate CPU states (by pressing "1"), we sometimes receive a malloc() error:

This problem only occurs when the screen is not large (tall) enough to display
all 32 processors at the same time.  I am pretty sure this problem has been
fixed elsewhere, because it used to happen in SLES8 and no longer occurs in
SLES9.  I was surprised to see it occur in RHEL4.

We also receive a an error when resizing the screen:

*** glibc detected *** realloc(): invalid next size: 0x600000000000d5


Version-Release number of selected component (if applicable):
procps-3.2.1-5.6
Comment 3 Karel Zak 2005-07-19 04:17:25 EDT
We don't support 32 Processors for RHEL3.

Note You need to log in before you can comment on or make changes to this bug.