Bug 1513823 - System upgrade fails with non-standard download directory
Summary: System upgrade fails with non-standard download directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1515172 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 03:21 UTC by Przemek Klosowski
Modified: 2018-06-28 08:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 08:39:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Przemek Klosowski 2017-11-16 03:21:39 UTC
Description of problem:
 
My system is a Fedora 26, (upgraded from earlier versions), and I am trying to upgrade in-place to F27. The dnf-based system upgrade requires large amount of space on the root filesystem; I believe the default requires 7+GB for the RPM download and 7+GB of free space for the actual upgrade. Since my root partition doesn't have that, I tried to use a non-standard download directory. The distribution download succeeded  but the subsequent reboot/update fails out.

Version-Release number of selected component (if applicable):
python3-dnf-plugin-system-upgrade-2.0.3-1.fc26.noarch

How reproducible: I tried and failed several times


Steps to Reproduce:
1.dnf system-upgrade download --destdir=/home/system-upgrade/fedora-cba4cf65782eccda/packages --releasever=27 --downloadonly --allowerasing
2.dnf system-upgrade reboot --destdir=/home/system-upgrade/fedora-cba4cf65782eccda/packages --releasever=27 --downloadonly --allowerasing


Actual results:
.....
dnf[931]:  realmd x86_64 0.16.3-7.fc27          fedora            227 k
dnf[931]:  recode x86_64 3.6-46.fc27            fedora            723 k
systemd[1]: dnf-system-upgrade.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start System Upgrade using DNF.
systemd[1]: dnf-system-upgrade.service: Unit entered failed state.
audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dnf-system-upgrade comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
systemd[1]: dnf-system-upgrade.service: Failed with result 'exit-code'.


Expected results: successful system update from f26 to f27


Additional info:

Comment 1 Richard Morehouse 2017-11-17 23:09:33 UTC
when i try 
dnf system-upgrade download --releasever=27 --refresh --allowerasing 
it says i need 1535M more space on /
but when i use 
dnf system-upgrade download --releasever=27 --refresh --allowerasing --destdir=/data2/temp 

to use a different directory 
it says that destdir can only be used by the download or downloadonly command

Comment 2 Richard Morehouse 2017-11-17 23:18:45 UTC
after i was able to free up space on the / filesystem i was able to upgrade

when i updated previously from fedora 25 to 26 i used the following and had no problems

dnf system-upgrade download --refresh --releasever=26 --allowerasing --datadir=/data/temp

this did not work and it said that datadir was not a valid parameter
dnf system-upgrade download --refresh --releasever=27 --allowerasing --datadir=/data/temp

Comment 3 Bert DeKnuydt 2017-11-21 11:54:19 UTC
I have the same problem ...

Fedora 25 --> 26

  > dnf system-upgrade download --releasever 26 --datadir=/usr/data/upgrade/rpms -y
  > dnf system-upgrade reboot

  Does the job. So simple and good...

Fedora 26 --> 27

  > dnf system-upgrade download --releasever 27 --destdir=/usr/data/upgrade/rpms

  Fails saying that '--destdir must be used with --downloadonly or download command' which is _is_.
  Adding --downloadonly circumvents this:

  > dnf system-upgrade download --releasever 27 --downloadonly --destdir=/usr/data/upgrade/rpms -y

  (Does indeed download the stuff as before)

  > dnf system-upgrade reboot

  Reboots the system, starts the upgrade procedure, but fails trying to ... download, as there is no
  network during an upgrade... Crashes and reboots with no work done.

  > dnf system-upgrade reboot --destdir=/usr/data/upgrade/rpms
 
  Says  "--destdir must be used with --downloadonly or download command"

I guess the 'new' version was never tested on anything but the most trivial case..

I ended up using the following workaround...

  > rm -rf /var/lib/dnf/system-upgrade
  > ln -s /usr/data/upgrade/system-upgrade /var/lib/dnf/system-upgrade
  > dnf system-upgrade download --releasever 27 -y
  > dnf system-upgrade reboot

Comment 4 Marek Blaha 2017-11-30 10:01:00 UTC
*** Bug 1515172 has been marked as a duplicate of this bug. ***

Comment 6 Fedora End Of Life 2018-05-03 08:16:28 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 7 Jaroslav Mracek 2018-06-28 08:39:03 UTC
The issue is solved by dnf-plugins-extras-3.0.0-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.