Bug 1513900 - 'Top 5 Utilization by Bricks' panel
Summary: 'Top 5 Utilization by Bricks' panel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 09:09 UTC by Lubos Trilety
Modified: 2017-12-18 04:39 UTC (History)
5 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-4.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
Top 5 Utilization by Bricks (128.27 KB, image/png)
2017-11-16 09:09 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Lubos Trilety 2017-11-16 09:09:05 UTC
Created attachment 1353331 [details]
Top 5 Utilization by Bricks

Description of problem:
'Top 5 Utilization by Bricks' panel doesn't show top 5 most used bricks.
E.g.
I have 2 bricks almost full, there's already two alerts present in RHGSWA, but they are not present in the panel at all.
BTW all bricks have correct capacity utilisation on Bricks dashboard.


Version-Release number of selected component (if applicable):
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install Gluster and connect RHGSWA
2. Create some volume
3. Load some data

Actual results:
There's no top 5 bricks ordered by capacity used.

Expected results:
There should be 5 most used bricks in the table.

Additional info:
I had 2 almost fully used bricks
ltrilety-usm2-gl5.<domain>:/mnt/brick_beta_arbiter_2/2
ltrilety-usm2-gl4.<domain>:/mnt/brick_beta_arbiter_2/2
spacefree: 16384Bytes
spacetotal: 21346910208Bytes

4 bricks where 17.35% of capacity was used
ltrilety-usm2-gl1.<domain>:/mnt/brick_beta_arbiter_1/1
ltrilety-usm2-gl2.<domain>:/mnt/brick_beta_arbiter_1/1
ltrilety-usm2-gl4.<domain>:/mnt/brick_beta_arbiter_3/3
ltrilety-usm2-gl5.<domain>:/mnt/brick_beta_arbiter_3/3
spacefree: 18166497280Bytes
spacetotal: 21346910208Bytes

2 bricks 14.90% used
ltrilety-usm2-gl4.<domain>:/mnt/brick_beta_arbiter_3/3
ltrilety-usm2-gl5.<domain>:/mnt/brick_beta_arbiter_3/3
spacefree: 17642209280Bytes
spacetotal: 21346910208Bytes

see screenshot what 'Top 5 Utilization by Bricks' panel shows

Comment 2 Rochelle 2017-11-23 09:28:49 UTC
verified with : tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch build.

Ran IO's on the volume and filled bricks partially. Utilization of brick space was correctly reflected on the Grafana dashboard.

Moving this bug to verified.

Comment 4 errata-xmlrpc 2017-12-18 04:39:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.