Bug 1514007 - Objects left after calling radosgw-admin bucket rm --purge-objects
Summary: Objects left after calling radosgw-admin bucket rm --purge-objects
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 3.*
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
Erin Donnelly
URL:
Whiteboard:
: 1504912 (view as bug list)
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-11-16 13:32 UTC by Orit Wasserman
Modified: 2019-08-22 05:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
.Object leaking can occur after using `radosgw-admin bucket rm --purge-objects` In the Ceph Object Gateway, the `radosgw-admin bucket rm --purge-objects` command is supposed to remove all object from a bucket. However, in some cases, some of the objects are left in the bucket. This is caused by the `RGWRados::gc_aio_operate()` operation abandoning on shutdown. To work around this problem, remove the objects by using the `rados rm` command.
Clone Of:
Environment:
Last Closed: 2019-08-22 05:23:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 22133 None None None 2017-11-16 13:32:13 UTC

Description Orit Wasserman 2017-11-16 13:32:14 UTC
Description of problem:
There could be object leaking after calling radosgw-admin bucket rm  --purge-objects.
this due to RGWRados::gc_aio_operate() ops abandoned on shutdown.

Version-Release number of selected component (if applicable):


How reproducible:
Create a large bucket

Steps to Reproduce:
1. remove the bucket
2.
3.

Actual results:
some of the objects are left

Expected results:
No objects left

Additional info:

Comment 9 Giridhar Ramaraju 2019-08-05 13:10:27 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 10 Giridhar Ramaraju 2019-08-05 13:11:31 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 11 Tejas 2019-08-22 05:20:57 UTC
*** Bug 1504912 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.