Bug 151415 - Need to add mod_jk package
Summary: Need to add mod_jk package
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-17 18:26 UTC by Anthony Green
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 08:39:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anthony Green 2005-03-17 18:26:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
Sorry for filing this against httpd, but I wasn't sure what else to do with it.

FC4test1 includes the Apache httpd and tomcat projects, but is missing the important bits that makes them work together! mod_jk.

This package is easily borrowed from JPackage.org, like many of our other packages. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to hook tomcat up to httpd.  

  

Additional info:

Comment 1 Joe Orton 2005-03-19 19:23:49 UTC
Gary, what's the plan here?  It's not clear yet whether we'll be able to ship
httpd 2.2 with its mod_ajp.

Comment 2 Joe Orton 2005-03-24 09:09:43 UTC
It does look like the currently recommended connector is mod_jk, until we can
ship 2.2 with mod_proxy_ajp:

http://jakarta.apache.org/tomcat/faq/connectors.html#vs

Comment 3 Gary Benson 2005-04-04 13:24:02 UTC
mod_jk is now built in dist-fc4.

Comment 4 Anthony Green 2005-04-12 12:11:51 UTC
Why don't I see this package in rawhide?

Comment 5 Gary Benson 2005-04-12 12:39:42 UTC
Dunno. Maybe Elliot does?

Comment 6 Thomas Fitzsimmons 2005-04-12 21:30:32 UTC
$ latest-pkg dist-fc4 mod_jk
/mnt/redhat/beehive/comps/dist/fc4/mod_jk/1.2.6-3jpp_1fc/SRPMS/mod_jk-1.2.6-3jpp_1fc.src.rpm

$ latest-pkg --arch=i386 dist-fc4 mod_jk
/mnt/redhat/beehive/comps/dist/fc4/mod_jk/1.2.6-3jpp_1fc/i386/mod_jk-debuginfo-1.2.6-3jpp_1fc.i386.rpm

I'm not sure what's going on here.


Comment 7 Elliot Lee 2005-04-19 20:12:21 UTC
The package is definitely in rawhide. What steps are you taking in looking for
it there?

Comment 9 Jeremy Katz 2005-04-27 23:35:19 UTC
No binaries got built...  it looks like there's something in the specfile
screwing things up.

Comment 10 Gary Benson 2005-04-28 16:14:30 UTC
That's wierd, the debuginfo package gets built, but not the main package...

Comment 11 Gary Benson 2005-04-29 08:39:45 UTC
Fixed in mod_jk-1.2.6-3jpp_2fc


Note You need to log in before you can comment on or make changes to this bug.