Bug 151438 - xfsprogs should be compiled with NDEBUG
xfsprogs should be compiled with NDEBUG
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 18:15 EST by Daniel Tschan
Modified: 2013-07-02 22:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-02 10:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Tschan 2005-03-17 18:15:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
According to the XFS developers at SGI, xfsprogs should be compiled with NDEBUG. Otherwise some tools (e.g. xfs_repair) may not run to completion because of assertions activated in debug mode.

See also the following mail thread: <http://oss.sgi.com/archives/linux-xfs/2005-03/msg00038.html>


Version-Release number of selected component (if applicable):
xfsprogs-2.6.13

How reproducible:
Sometimes

Steps to Reproduce:
1. Run xfs_repair on a damaged xfs filesystem
2.
3.
  

Actual Results:  xfs_repair aborts prematurely because of a failed assertion.

Expected Results:  xfs_repair should run to completion.

Additional info:
Comment 1 Florian La Roche 2006-04-02 10:26:35 EDT
Fixed in current rpm packages. 2.7.11 should also appear tomorrow in the
FC-development tree.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.