Red Hat Bugzilla – 1514383 – After restoring satellite backup using satellite-clone utility, upon login to webui/accessing "All Hosts" and "Content Hosts" page fails with error "ActiveRecord::SubclassNotFound:" for HostStatus::ExecutionStatus
Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
After restoring satellite backup using satellite-clone utility, upon login to webui/accessing "All Hosts" and "Content Hosts" page fails with error "ActiveRecord::SubclassNotFound:" for HostStatus::ExecutionStatus
Description of problem:
After restoring satellite backup using satellite-clone utility, upon login to webui/accessing "All Hosts" and "Content Hosts" page fails with error :
2017-11-17 14:53:59 1663b3d9 [app] [W] Action failed
| ActiveRecord::SubclassNotFound: The single-table inheritance mechanism failed to locate the subclass: 'HostStatus::ExecutionStatus'. This error is raised because the column 'type' is reserved for storing the class in case of inheritance. Please rename this column if you didn't intend it to be used for storing the inheritance class or overwrite HostStatus::Status.inheritance_column to use another column for that information.
| /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/inheritance.rb:161:in `rescue in find_sti_class'
| /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/inheritance.rb:155:in `find_sti_class'
| /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/inheritance.rb:144:in `discriminate_class_for_record'
- Is this a possible bug with clone utility?
- Tried to execute satellite-installer with --upgrade and it was successful but issue still persists
Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 24
Steps to Reproduce:
1. Took backup of working satellite v 6.2 using katello-backup
2. Installed fresh RHEL 7 system and executed satellite-clone task "ansible-playbook satellite-clone-playbook.yml"
3. Login worked successfully but unable to access "All Hosts" and "Content Hosts" page.
While accessing it fails with above traceback.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2018:0330