Bug 151455 - rpmbuild of FreeType fails if with_freetype1==0
rpmbuild of FreeType fails if with_freetype1==0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 22:10 EST by Mike Duigou
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.2.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 13:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Duigou 2005-03-17 22:10:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050313 Fedora/1.7.6-0.cvs.20050313

Description of problem:
Building of freetype fails if you attempt to disable building of freetype 1.X. The failure is due to some of the build steps not being correctly conditionalized for freetype 1.x being deconfigured.

Version-Release number of selected component (if applicable):
freetype-2.1.9-2

How reproducible:
Always

Steps to Reproduce:
1. Install freetype-2.1.9.src.rpm
2. Edit freetype.spec file to disable with_freetype1 (%define with_freetype1	0)
3. rpmbuild -ba SPECS/freetype.spec
4. kaboom!
  

Actual Results:  ....
+ aclocal
net.m4:35: warning: underquoted definition of AC_LIBRARY_NET
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
configure.in:62: error: AC_REQUIRE: cannot be used outside of an m4_defun'd macro
configure.in:62: AC_PROG_MAKE_SET is required by...
configure.in:62: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
error: Bad exit status from /usr/src/redhat/tmp/rpm-tmp.12568 (%prep)


Expected Results:  build completes 

Additional info:

Patch that fixes it:

115a116
> %if %{with_freetype1}
120a122
> %endif
Comment 1 David Zeuthen 2005-03-17 22:23:44 EST
Please provide a unified patch (option -u). Thanks.
Comment 2 Matthias Clasen 2006-09-10 13:35:04 EDT
Probably obsolete, since we dropped freetype 1.x from the rpm now.

Note You need to log in before you can comment on or make changes to this bug.