Bug 1514577 - Import cluster fails with KeyError
Summary: Import cluster fails with KeyError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-commons
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: Sweta Anandpara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 19:29 UTC by Nishanth Thomas
Modified: 2017-12-18 04:37 UTC (History)
7 users (show)

Fixed In Version: tendrl-commons-1.5.4-3.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github Tendrl commons issues 780 None None None 2017-11-17 19:29:55 UTC
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Nishanth Thomas 2017-11-17 19:29:56 UTC
Description of problem:


Import cluster fails while getting node interface If an interface does not have ip address. It raises KeyError and import cluster is fails

Comment 3 Filip Balák 2017-11-28 09:34:19 UTC
Could you please provide reproducer and expected output for this bug?

Comment 4 Sweta Anandpara 2017-11-30 09:26:59 UTC
Had a cluster which had its IPs on ovirtmgmt interface. Imported that into Web-Admin and that got successfully executed. Did not see any error. 

Moving this bug to verified.

tendrl-grafana-plugins-1.5.4-8.el7rhgs.noarch
tendrl-selinux-1.5.4-1.el7rhgs.noarch
tendrl-node-agent-1.5.4-8.el7rhgs.noarch
tendrl-ansible-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
tendrl-grafana-selinux-1.5.4-1.el7rhgs.noarch
tendrl-commons-1.5.4-5.el7rhgs.noarch
tendrl-api-1.5.4-3.el7rhgs.noarch
tendrl-api-httpd-1.5.4-3.el7rhgs.noarch
tendrl-notifier-1.5.4-5.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch

Comment 6 errata-xmlrpc 2017-12-18 04:37:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.