Bug 15146 - Switching back to text mode
Summary: Switching back to text mode
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 19:03 UTC by Radu Cornea
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 18:18:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Radu Cornea 2000-08-02 19:03:43 UTC
In conjunction with an ATI Rage Fury Pro AGP (32 Mb), Xfree86 4.0.1 
occazionally, fails to switch back to text mode from graphical mode, 
leaving the screen all scrambled. If X is started by typing the command 
(though without seeing anything), everithing works fine again (but in 
graphical mode) until coming back to text mode.

Comment 1 Bill Nottingham 2000-08-03 03:15:45 UTC
That's an r128 card, correct?

Comment 2 Brian Smith 2000-08-07 13:05:36 UTC
I have the same problem with an XPert 128 card (also Rage 128 chip). At least, 
I think it's the same problem. It sounds like the original poster was using 
startx and getting the problem when exiting X. I use gdm and have the problem 
when trying to switch to text mode with Ctrl-Alt-F1 (or 2 or 3 or ...). I've 
been just doing a Ctrl-Alt-Del reboot when it happens. Also, it doesn't happen 
every time, it seems to be dependent on how long X has been running.

Comment 3 Bill Nottingham 2000-08-15 18:18:27 UTC
Is this improved at all with the current rawhide packages?

Comment 4 Preston Brown 2000-08-15 19:14:25 UTC
customer switched back to stable, we don't know if resolved.

Comment 5 Brian Smith 2000-08-16 01:43:12 UTC
Hey, I've still got 7.0 beta on my machine and I've managed to fix the problem
by doing

modprobe agpgart

in my rc.local file so it runs before gdm starts up. I saw this on some
discussion group about xfree86 4.01 and tried it and it worked beautifully. This
is on a Xpert 128 AGP w/16M RAM.


Note You need to log in before you can comment on or make changes to this bug.