Bug 151467 - hidd needs to be started in runlevels 3 and 5 (and not 6) for USB/Bluetooth mice and keyboards
hidd needs to be started in runlevels 3 and 5 (and not 6) for USB/Bluetooth m...
Status: CLOSED DUPLICATE of bug 155831
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-18 05:28 EST by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-02 10:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-03-18 05:28:22 EST
I am using a Logitech MX900 USB/Bluetooth mouse, which unfortunately does not
work with X upon bootup.  I have to log in, alt-f2, launch a gnome-terminal and
then manually activate /etc/init.d/hidd .

Current init script looks like this:

# chkconfig:    - 26 89

This really should be:     - 235 89

Not too sure quite why one would want to run hidd in runlevel 6!

If a system has the bluez-utils package installed, it should at least start in a
runlevel where it's services are required.
This may also include runlevel 3 (such as when there is a USB/Bluetooth keyboard).

Current bluez-utils is 2.15-4.
Comment 1 Reuben Farrelly 2005-04-26 05:31:32 EDT
Oops.  Ok I got that a bit wrong...

But I still think the statement should be:

# chkconfig 5 26 89

at the very least.  If the user has a bluetooth mouse or keyboard and therefore
requires hidd, they are almost certainly going to want it to run under X
(runlevel 5).
Comment 2 Miloslav Trmač 2005-05-02 10:52:04 EDT

*** This bug has been marked as a duplicate of 155831 ***

Note You need to log in before you can comment on or make changes to this bug.