Bug 1514830 - Missing "which" dependency
Summary: Missing "which" dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: powerline
Version: 26
Hardware: armv7hl
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 19:12 UTC by dark147123
Modified: 2018-03-13 23:12 UTC (History)
2 users (show)

Fixed In Version: powerline-2.6-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-13 23:12:35 UTC


Attachments (Terms of Use)

Description dark147123 2017-11-18 19:12:28 UTC
Description of problem:
Which is not installed as a dependency when installing Powerline.
This may only be relevant to using Powerline over SSH.

Version-Release number of selected component (if applicable):


How reproducible:
Should be easily reproducible.

Steps to Reproduce:
0. Install Powerline on local system.
1. Install Fedora 26 Arm Minimal.
2. Install Powerline on the remote system as per instructions here (no customizations, install for bash): https://fedoramagazine.org/add-power-terminal-powerline/
3. Close SSH and reopen the connection.

Actual results:
I get theses errors and no visual change.
"-bash: which: command not found
-bash: which: command not found
-bash: /usr/share/powerline/bash/../../../scripts/powerline-config: No such file or directory
-bash: /usr/share/powerline/bash/../../../scripts/powerline-config: No such file or directory"

Expected results:
Powerline changes the look of the terminal.

Workaround:
Install which and restart SSH connection.

Additional info:

Comment 1 Mike Goodwin 2018-02-22 22:42:36 UTC
This should have been fixed in powerline-2.6-2.fc26 (
FEDORA-2017-222bbba94a) back in July 2017. Were you just not updated then?

Powerline is an unusual package, in that during the building of the package it decides to do differing things based on whether or not the C client succeeds (instead of just failing like it should imho) See: https://github.com/powerline/powerline/blob/develop/setup.py#L49 

So what had happened to everyone then is that a package with the bash and/or python variants of the client got released (and they are enormously slower.) I checked and the bash variant does in fact require socat, sed, and which. 

So it totally possible that a build slipped by during one of the automated rebuilds that temporarily enabled the bash/socat version or the python version instead of the preferred C client.

Today, with powerline-2.6-5 i've checked the arm build logs and none of them have the "instead of C version" string in them, which indicates to me that they are using the C client. I also have a RPi3 with Fedora 27 on it and it is also using the correct client. 

Since I've checked this out and I think I know the original reason for this bug, I am closing the issue.

Comment 2 Fedora Update System 2018-02-28 10:38:44 UTC
powerline-2.6-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a07ac6bb95

Comment 3 Fedora Update System 2018-02-28 18:09:51 UTC
powerline-2.6-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a07ac6bb95

Comment 4 Fedora Update System 2018-03-13 23:12:35 UTC
powerline-2.6-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.