Bug 1515053 - Review Request: asv - Airspeed Velocity: A simple Python history benchmarking tool
Summary: Review Request: asv - Airspeed Velocity: A simple Python history benchmarking...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: python-pyphi
TreeView+ depends on / blocked
 
Reported: 2017-11-20 04:04 UTC by Elliott Sales de Andrade
Modified: 2018-12-22 20:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-22 03:01:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sanjay.ankur: fedora-review+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1649274 None CLOSED Should "asizeof.py" be marked as "bundled" in the spec? 2019-03-30 01:03 UTC

Internal Trackers: 1649274

Description Elliott Sales de Andrade 2017-11-20 04:04:49 UTC
Spec URL: http://qulogic.fedorapeople.org//asv.spec
SRPM URL: http://qulogic.fedorapeople.org//asv-0.2.1-1.fc26.src.rpm

Description:
Airspeed Velocity (asv) is a tool for benchmarking Python packages over their
lifetime. It is primarily designed to benchmark a single project over its
lifetime using a given suite of benchmarks. The results are displayed in an
interactive web frontend that requires only a basic static webserver to host.

Comment 1 Elliott Sales de Andrade 2017-11-20 04:04:54 UTC
This package built on koji:  https://koji.fedoraproject.org/koji/taskinfo?taskID=23247234

Comment 2 Aivar Annamaa 2017-11-21 13:53:48 UTC
I think you should put six and colorama as BuildRequires, not as Sources

Comment 3 Elliott Sales de Andrade 2017-11-22 05:54:19 UTC
No, I need the source to build wheels, and I need exactly the specified versions to run tests.

Comment 4 Ankur Sinha (FranciscoD) 2018-08-20 21:48:44 UTC
Hi Elliot,

I can review this package for you. I need asv for pyphi (https://github.com/wmayner/pyphi/).

Cheers,
Ankur

Comment 5 pav 2018-09-16 12:23:38 UTC
v0.3 is out, doesn't need extra packages for tests.

Comment 6 Elliott Sales de Andrade 2018-10-20 21:43:13 UTC
OK, updated to 0.3:

Spec URL: https://qulogic.fedorapeople.org/asv.spec
SRPM URL: https://qulogic.fedorapeople.org/asv-0.3-1.fc28.src.rpm

koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=30351792

Comment 7 Elliott Sales de Andrade 2018-10-21 09:45:10 UTC
Updated to 0.3.1:

Spec URL: https://qulogic.fedorapeople.org/asv.spec
SRPM URL: https://qulogic.fedorapeople.org/asv-0.3.1-1.fc28.src.rpm

koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=30363453

Comment 8 Ankur Sinha (FranciscoD) 2018-10-25 11:43:19 UTC
In general, the build is fine, but there are a few bundling issues that must be
looked at.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- All build dependencies are listed in BuildRequires, except for any that
  are listed in the exceptions section of Packaging Guidelines.
  Note: These BR are not needed: gcc-c++
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2

Please double check if g++ is required by this package.

There are a few bundling issues here:

- I'm not sure whether the various JS libraries that you're including can be
  bundled. The guidelines here say they must be packaged separately too:
  https://fedoraproject.org/wiki/JavaScript_libraries_packaging_guideline_draft

- extern/asizeof is part of Pympler which is in Fedora. So that should be used
  instead of the bundled copy:
  https://src.fedoraproject.org/rpms/python-Pympler

- extern/json-minify is bundled too. I expect this needs to be packaged
  separately also as I've not been able to find it in the repos:
  https://pypi.org/project/JSON_minify/

===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD 3-clause "New" or "Revised" License", "Expat License",
     "Unknown or generated", "*No copyright* BSD (unspecified)". 188 files
     have unknown license. Detailed output of licensecheck in
     /home/asinha/1515053-asv/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[!]: If the package is under multiple licenses, the licensing breakdown
     must be documented in the spec.
May change after unbundling. Please re-check.

[x]: Package does not own files or directories owned by other packages.
[x]: %build honors applicable compiler flags or justifies otherwise.
[!]: Package contains no bundled libraries without FPC exception.
- Bundles JS bits

[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
- Python, but an application so it does not need a python- prefix.

[x]: Package does not generate any conflict.

[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[!]: Avoid bundling fonts in non-fonts packages.
     Note: Package contains font files
I haven't been able to locate them. Please check for these.

[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in asv-doc
     , asv-debuginfo , asv-debugsource

[?]: Package functions as described.
Not checked. Please do.

[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[-]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
     Note: Arch-ed rpms have a total of 6881280 bytes in /usr/share
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: asv-0.3.1-1.fc28.x86_64.rpm
          asv-doc-0.3.1-1.fc28.x86_64.rpm
          asv-debuginfo-0.3.1-1.fc28.x86_64.rpm
          asv-debugsource-0.3.1-1.fc28.x86_64.rpm
          asv-0.3.1-1.fc28.src.rpm
asv.x86_64: W: spelling-error Summary(en_US) benchmarking -> bench marking, bench-marking, benchmark
asv.x86_64: W: spelling-error %description -l en_US benchmarking -> bench marking, bench-marking, benchmark
asv.x86_64: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
asv.x86_64: W: spelling-error %description -l en_US webserver -> web server, web-server, observer
asv.x86_64: E: wrong-script-interpreter /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py /usr/bin/env python
asv.x86_64: E: non-executable-script /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py 644 /usr/bin/env python
asv.x86_64: W: no-manual-page-for-binary asv
asv-doc.x86_64: W: summary-not-capitalized C asv documentation
asv.src: W: spelling-error Summary(en_US) benchmarking -> bench marking, bench-marking, benchmark
asv.src: W: spelling-error %description -l en_US benchmarking -> bench marking, bench-marking, benchmark
asv.src: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
asv.src: W: spelling-error %description -l en_US webserver -> web server, web-server, observer
5 packages and 0 specfiles checked; 2 errors, 10 warnings.


Rpmlint (debuginfo)
-------------------
Checking: asv-debuginfo-0.3.1-1.fc28.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.


Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory

- This could be improved as "Documentation for %{name}" which would also get
  rid of this error.
asv-doc.x86_64: W: summary-not-capitalized C asv documentation

- These are false positives:
asv-doc.x86_64: W: invalid-url URL: https://github.com/airspeed-velocity/asv <urlopen error [Errno -2] Name or service not known>
asv-debuginfo.x86_64: W: invalid-url URL: https://github.com/airspeed-velocity/asv <urlopen error [Errno -2] Name or service not known>
asv-debugsource.x86_64: W: invalid-url URL: https://github.com/airspeed-velocity/asv <urlopen error [Errno -2] Name or service not known>

- Cosmetic issues that can be tweaked.
asv.x86_64: W: spelling-error Summary(en_US) benchmarking -> bench marking, bench-marking, benchmark
asv.x86_64: W: spelling-error %description -l en_US benchmarking -> bench marking, bench-marking, benchmark
asv.x86_64: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
asv.x86_64: W: spelling-error %description -l en_US webserver -> web server, web-server, observer


- False positive.
asv.x86_64: W: invalid-url URL: https://github.com/airspeed-velocity/asv <urlopen error [Errno -2] Name or service not known>

- These should likely be removed (see comment on bundling above)
asv.x86_64: E: wrong-script-interpreter /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py /usr/bin/env python
asv.x86_64: E: non-executable-script /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py 644 /usr/bin/env python

- Upstream does not seem to provide one, so this is OK.
asv.x86_64: W: no-manual-page-for-binary asv
4 packages and 0 specfiles checked; 2 errors, 10 warnings.


Requires
--------
asv-doc (rpmlib, GLIBC filtered):

asv-debuginfo (rpmlib, GLIBC filtered):

asv-debugsource (rpmlib, GLIBC filtered):

asv (rpmlib, GLIBC filtered):
    /usr/bin/python3
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libpthread.so.0()(64bit)
    libpython3.6m.so.1.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    python(abi)
    python3-setuptools
    python3-six
    rtld(GNU_HASH)



Provides
--------
asv-doc:
    asv-doc
    asv-doc(x86-64)

asv-debuginfo:
    asv-debuginfo
    asv-debuginfo(x86-64)
    debuginfo(build-id)

asv-debugsource:
    asv-debugsource
    asv-debugsource(x86-64)

asv:
    asv
    asv(x86-64)
    python3-asv(x86-64)
    python3.6dist(asv)
    python3dist(asv)



Unversioned so-files
--------------------
asv: /usr/lib64/python3.6/site-packages/asv/_rangemedian.cpython-36m-x86_64-linux-gnu.so

- That's fine. False positive.

Source checksums
----------------
https://files.pythonhosted.org/packages/source/a/asv/asv-0.3.1.tar.gz :
  CHECKSUM(SHA256) this package     : 82a3128cb6598a683db62aa51d74bf7dd5a48a5b357c9d0aee43ed1f92782f15
  CHECKSUM(SHA256) upstream package : 82a3128cb6598a683db62aa51d74bf7dd5a48a5b357c9d0aee43ed1f92782f15


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1515053
Buildroot used: fedora-28-x86_64
Active plugins: Python, Generic, Shell-api, C/C++
Disabled plugins: Java, SugarActivity, fonts, Haskell, Ocaml, Perl, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 9 Elliott Sales de Andrade 2018-10-25 23:15:51 UTC
(In reply to Ankur Sinha (FranciscoD) from comment #8)
> In general, the build is fine, but there are a few bundling issues that must
> be
> looked at.
> 
> Issues:
> =======
> - All build dependencies are listed in BuildRequires, except for any that
>   are listed in the exceptions section of Packaging Guidelines.
>   Note: These BR are not needed: gcc-c++
>   See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2
> 
> Please double check if g++ is required by this package.

That lint is outdated. gcc-c++ must be listed now.

> There are a few bundling issues here:
> 
> - I'm not sure whether the various JS libraries that you're including can be
>   bundled. The guidelines here say they must be packaged separately too:
>  
> https://fedoraproject.org/wiki/JavaScript_libraries_packaging_guideline_draft

Unfortunately, the JS ecosystem never really seemed to have taken off as far as packages go... As you can see that guideline has been a draft for 10 years.

> - extern/asizeof is part of Pympler which is in Fedora. So that should be
> used
>   instead of the bundled copy:
>   https://src.fedoraproject.org/rpms/python-Pympler

It's a bundled library in pympler too.

> - extern/json-minify is bundled too. I expect this needs to be packaged
>   separately also as I've not been able to find it in the repos:
>   https://pypi.org/project/JSON_minify/

I think the package never existed before, so I will see if I can unbundle it upstream.

> ===== SHOULD items =====
> 
> Generic:
> [!]: Avoid bundling fonts in non-fonts packages.
>      Note: Package contains font files
> I haven't been able to locate them. Please check for these.

I don't see any either.

> ===== EXTRA items =====
> 

> Rpmlint (installed packages)
> ----------------------------
> - This could be improved as "Documentation for %{name}" which would also get
>   rid of this error.
> asv-doc.x86_64: W: summary-not-capitalized C asv documentation
> 

Will fix.

> - These should likely be removed (see comment on bundling above)
> asv.x86_64: E: wrong-script-interpreter
> /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py /usr/bin/env python
> asv.x86_64: E: non-executable-script
> /usr/lib64/python3.6/site-packages/asv/extern/asizeof.py 644 /usr/bin/env
> python
>

Will fix.

Comment 10 Ankur Sinha (FranciscoD) 2018-11-03 09:29:09 UTC
(In reply to Elliott Sales de Andrade from comment #9)
> (In reply to Ankur Sinha (FranciscoD) from comment #8)
<snip>
> 
> > There are a few bundling issues here:
> > 
> > - I'm not sure whether the various JS libraries that you're including can be
> >   bundled. The guidelines here say they must be packaged separately too:
> >  
> > https://fedoraproject.org/wiki/JavaScript_libraries_packaging_guideline_draft
> 
> Unfortunately, the JS ecosystem never really seemed to have taken off as far
> as packages go... As you can see that guideline has been a draft for 10
> years.

Yes, I understand that, but it still is bundling. Maybe it'll be worth quickly checking up on the devel list to see how this should be handled? 

> 
> > - extern/asizeof is part of Pympler which is in Fedora. So that should be
> > used
> >   instead of the bundled copy:
> >   https://src.fedoraproject.org/rpms/python-Pympler
> 
> It's a bundled library in pympler too.

Ugh. This shouldn't be, but I reckon it's too tiny a module to call it "bundling", even though it is.

> 
> > - extern/json-minify is bundled too. I expect this needs to be packaged
> >   separately also as I've not been able to find it in the repos:
> >   https://pypi.org/project/JSON_minify/
> 
> I think the package never existed before, so I will see if I can unbundle it
> upstream.

+1

Cheers,
Ankur

Comment 11 Elliott Sales de Andrade 2018-11-12 07:00:59 UTC
(In reply to Ankur Sinha (FranciscoD) from comment #10)
> (In reply to Elliott Sales de Andrade from comment #9)
> > (In reply to Ankur Sinha (FranciscoD) from comment #8)
> > > - extern/asizeof is part of Pympler which is in Fedora. So that should be
> > > used
> > >   instead of the bundled copy:
> > >   https://src.fedoraproject.org/rpms/python-Pympler
> > 
> > It's a bundled library in pympler too.
> 
> Ugh. This shouldn't be, but I reckon it's too tiny a module to call it
> "bundling", even though it is.
> 

I don't see why; there's no upstream library. It's basically copied off a cookbook site and I'd consider it at most a copylib.

Now with unbundled JSON-minify, jQuery, and flot:

Spec URL: https://qulogic.fedorapeople.org/asv.spec
SRPM URL: https://qulogic.fedorapeople.org/asv-0.3.1-2.fc28.src.rpm

koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=30820122

Comment 12 Ankur Sinha (FranciscoD) 2018-11-13 10:05:20 UTC
Almost there. One or two issues remaining.

I've filed a bug against Pympler asking if asizeof should be marked as bundled here: https://bugzilla.redhat.com/show_bug.cgi?id=1649274 (I expect it should, like we do in nibabel https://src.fedoraproject.org/rpms/python-nibabel/blob/master/f/python-nibabel.spec#_46)

rpmlint still catches a few issues:

asv.x86_64: E: wrong-script-interpreter /usr/lib64/python3.7/site-packages/asv/extern/asizeof.py /usr/bin/env python
asv.x86_64: E: non-executable-script /usr/lib64/python3.7/site-packages/asv/extern/asizeof.py 644 /usr/bin/env python

Please correct these.

asv.x86_64: W: dangling-symlink /usr/lib64/python3.7/site-packages/asv/www/vendor/jquery-3.2.1.js /usr/share/javascript/jquery/3.2.1/jquery.js
asv.x86_64: W: dangling-symlink /usr/lib64/python3.7/site-packages/asv/www/vendor/jquery.flot-0.8.3.categories.min.js /usr/lib/node_modules/flot/jquery.flot.categories.min.js
asv.x86_64: W: dangling-symlink /usr/lib64/python3.7/site-packages/asv/www/vendor/jquery.flot-0.8.3.min.js /usr/lib/node_modules/flot/jquery.flot.min.js
asv.x86_64: W: dangling-symlink /usr/lib64/python3.7/site-packages/asv/www/vendor/jquery.flot-0.8.3.selection.min.js /usr/lib/node_modules/flot/jquery.flot.selection.min.js
asv.x86_64: W: dangling-symlink /usr/lib64/python3.7/site-packages/asv/www/vendor/jquery.flot-0.8.3.time.min.js /usr/lib/node_modules/flot/jquery.flot.time.min.js

These need to be double checked. Pympler does something similar, so that could be used as reference:
https://src.fedoraproject.org/rpms/python-Pympler/blob/master/f/python-Pympler.spec#_70

Cheers,
Ankur

Comment 13 Elliott Sales de Andrade 2018-11-13 10:39:43 UTC
Removed the unnecessary shebang:

Spec URL: https://qulogic.fedorapeople.org/asv.spec
SRPM URL: https://qulogic.fedorapeople.org/asv-0.3.1-2.fc28.src.rpm

Didn't bother with a scratch build this time.

There doesn't appear to be anything wrong with the symlinks.

Comment 14 Ankur Sinha (FranciscoD) 2018-11-13 11:09:16 UTC
Great. Looks good now. XXX APPROVED XXX

Comment 15 Ankur Sinha (FranciscoD) 2018-11-13 11:33:28 UTC
Please mark asizeof as being bundled with the package before you import. The Pympler maintainers have agreed that it is the right thing to do too.

Comment 16 Ankur Sinha (FranciscoD) 2018-11-13 12:13:08 UTC
Please also correct the licenses---since you are not bundling the js stuff, there's no need for their licenses to be mentioned.

Comment 17 Gwyn Ciesla 2018-11-13 14:18:29 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/asv

Comment 18 Fedora Update System 2018-11-14 02:13:57 UTC
asv-0.3.1-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2b9bc7a14

Comment 19 Fedora Update System 2018-11-14 02:14:28 UTC
asv-0.3.1-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-847891183f

Comment 20 Fedora Update System 2018-11-15 04:53:40 UTC
asv-0.3.1-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2b9bc7a14

Comment 21 Fedora Update System 2018-11-15 06:01:52 UTC
asv-0.3.1-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-847891183f

Comment 22 pav 2018-12-01 13:40:19 UTC
It's missing "Requires: python3-json-minify"

Comment 23 Fedora Update System 2018-12-06 06:12:09 UTC
asv-0.3.1-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2b9bc7a14

Comment 24 Fedora Update System 2018-12-06 06:14:00 UTC
asv-0.3.1-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-847891183f

Comment 25 Fedora Update System 2018-12-07 03:15:52 UTC
asv-0.3.1-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f2b9bc7a14

Comment 26 Fedora Update System 2018-12-07 03:22:26 UTC
asv-0.3.1-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-847891183f

Comment 27 pav 2018-12-07 21:36:05 UTC
File "jquery-3.2.1.js" should be named "jquery-3.2.1.min.js", or you need to change the name in "index.html" in the patch you apply.

This stuff does have tests: you could enable the web tests, passing "--webdriver=ChromeHeadless" or "--webdriver=FirefoxHeadless" to pytest (with the necessary BuildRequires).

Comment 28 Elliott Sales de Andrade 2018-12-08 10:54:56 UTC
Thanks; I tried to set those up again and I think I have them working now. I don't think FirefoxHeadless works, or at least, I could not find the right thing to install to get it to work.

Comment 29 pav 2018-12-08 13:02:52 UTC
Firefox needs https://github.com/mozilla/geckodriver/ -- not packaged in Fedora currently I think.

Comment 30 Fedora Update System 2018-12-22 03:01:48 UTC
asv-0.3.1-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2018-12-22 20:00:27 UTC
asv-0.3.1-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.