Bug 151506 - 32/64 Bit Locking Problems
32/64 Bit Locking Problems
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 14:13 EST by R. Michael Richer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R. Michael Richer 2005-03-18 14:13:07 EST
Description of problem:

   Extremely Slow Performance and possible corruption accessing a CXFS 
filesystem with Samba.

Version-Release number of selected component (if applicable):

   Samba 3.0.9-1.3E.2
   kernel   2.4.21-27
   CXFS Client 3.2.2

How reproducible:

   Every time...

Steps to Reproduce:
1.   Access a file on the samba share
2.
3.
  
Actual results:
   EXTREMELY SLOW PERFORMANCE (instead of 2 minutes, it would be about 3 hours)

Expected results:
   Normal File Speed Access

Additional info:

    We are receiving the following in our logs:

Mar 18 13:41:37 athena smbd[24222]: [2005/03/18 13:41:37, 0] 
locking/posix.c:posix_fcntl_lock(658)
Mar 18 13:41:37 athena smbd[24222]:   an Invalid argument error. This can 
happen when using 64 bit lock offsets
Mar 18 13:41:37 athena smbd[24222]: [2005/03/18 13:41:37, 0] 
locking/posix.c:posix_fcntl_lock(659)
Mar 18 13:41:37 athena smbd[24222]:   on 32 bit NFS mounted file systems.
Mar 18 13:41:37 athena smbd[24222]: [2005/03/18 13:41:37, 0] 
locking/posix.c:posix_fcntl_lock(673)
Mar 18 13:41:37 athena smbd[24222]:   Count greater than 31 bits - retrying 
with 31 bit truncated length.
Mar 18 13:41:37 athena smbd[24222]: [2005/03/18 13:41:37, 0] 
locking/posix.c:posix_fcntl_lock(657)
Mar 18 13:41:37 athena smbd[24222]:   posix_fcntl_lock: WARNING: lock request 
at offset 0, length 9223372036854775808 returned

This is causing some extreme performance problems.  Disabling oplocks and level 
2 oplocks removes the error messages, but the performance still suffers. Anyone 
have any ideas on this one?

The filesystem (SGI CXFS) running on the RHEL 3.0 is exported via NFS, and is 
used by Samba.  No other server actually shares, although they are clients.
Comment 1 R. Michael Richer 2005-03-18 14:28:21 EST
Note: Copying the same files files with Windows Explorer does result in the 2 
minute result... Accessing the data files from any application however is 
causing the delay.
Comment 2 Jay Fenlason 2005-03-18 14:45:13 EST
Attach your /etc/samba/smb.conf file to this bug report, please. 
 
Do I understand that you're re-exporting via Samba a filesystem that you've 
mounted via NFS? 
Comment 3 R. Michael Richer 2005-03-18 15:01:19 EST
No it isn't NFS mounted.  The /local filesystem is seen to the linux box as an 
XFS mount.  (It is actually a CXFS partition which is a clustered version of 
XFS from SGI... It's similar to Redhat's GFS product.  It is seen as a local 
drive (i.e. all the SCSI drives are actually seen on the server)... 
This same filesystem is seen on 4 different servers as a local filesystem 
(rather than an NFS mounted one)... It's a clustered filesystem thing... ;)
Comment 4 R. Michael Richer 2005-03-18 15:05:57 EST
Sorry forgot the smb.conf

[global]
   workgroup = MIRAR
   server string =  Mirar File & Print Server
   hosts deny = ALL
   hosts allow = 192.168.1. 192.168.2. 192.168.10. 127.
   printcap name = cups
   load printers = no
   show add printer wizard = yes
   lpq cache time = 20
   use client driver = no
   printing = cups
 log file = /var/log/samba/%m.log
   max log size = 50
   security = user
  encrypt passwords = yes
  username map = /etc/samba/smbusers
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   interfaces = eth0
   bind interfaces only = yes
   local master = no
   os level = 10
   domain master = no
   preferred master = no
   domain logons = no
name resolve order = host wins lmhosts bcast
   wins support = no
   wins server = 192.168.1.22
   dns proxy = no
  netbios name = FP02

  ldap suffix = dc=mirarco,dc=org
  ldap machine suffix = ou=Computers
  ldap group suffix = ou=Group
  ldap user suffix = ou=People
  ldap idmap suffix = ou=People
  ldap filter = (&(uid=%u)(objectclass=sambaSamAccount))
  ldap admin dn = cn=root,dc=mirarco,dc=org
  ldap replication sleep = 2000

  passdb backend = ldapsam:ldap://192.168.1.22
  passwd program = /usr/local/sbin/smbldap-passwd.pl %u
  passwd chat = *New*password* %n\n *new*password* %n\n *successfully*

[homes]
   comment = Home Directories
   path = /home/%u/samba
   valid users = %S
   browseable = no
   writable = yes
   csc policy = disabled

[CompAdmin]
        comment = IMS Computer Administration
        path = /local/Projects/CompAdmin
        valid users = +NTCompAdmin
        read list = +NTCompAdmin
        write list = +NTCompAdmin
        force group = NTCompAdmin
        writable = Yes
        create mask = 0770
        directory mask = 02770
Comment 5 Jay Fenlason 2005-05-02 16:57:54 EDT
I built rpms of samba-3.0.15pre2 and put them up on 
http://people.redhat.com/fenlason/.samba3E/samba*3.0.15-0.pre2.3E.1.{i386,src}.rpm 
for testing.  Please try them an see if they work better than 3.0.9. 
Note that these are not QA'd or supported, and 3.0.15pre2 is not intended for 
production use.  There have been serveral changes to the directory handling 
code to try to clear up performance bottlenecks. 
Comment 6 R. Michael Richer 2005-05-12 08:40:04 EDT
I won't have time to test it out right away.  I am on vacation for 2 weeks ;)
... When I get back I'll give them a try.

Most appreciated
Comment 7 RHEL Product and Program Management 2007-10-19 15:06:07 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.