Bug 151534 - /dev/sg* entries not created for DLT drive and changer
/dev/sg* entries not created for DLT drive and changer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 154857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 18:21 EST by john.l.villalovos
Modified: 2014-03-16 22:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 22:55:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.l.villalovos 2005-03-18 18:21:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

Description of problem:
I have a DLT tape drive.  The /dev/sg0 and /dev/sg1 entries are not being created for it.

Here is kernel output:
(scsi0:A:4): 10.000MB/s transfers (10.000MHz, offset 15)
  Vendor: Quantum   Model: DLT4000           Rev: D782
  Type:   Sequential-Access                  ANSI SCSI revision: 02
  Vendor: ADIC      Model: FastStor DLT      Rev: D114
  Type:   Medium Changer                     ANSI SCSI revision: 02

I have manually created them for now in /etc/udev/devices/

Version-Release number of selected component (if applicable):
udev-039-10.FC3.7

How reproducible:
Always

Steps to Reproduce:
---

Additional info:
Comment 1 john.l.villalovos 2005-03-18 19:12:24 EST
Just a clarification.  It does create the /dev/nst0* entries for the tape drive.

So what is missing is the /dev/sg1 entry for the tape changer.
Comment 2 Harald Hoyer 2005-03-21 05:36:06 EST
/etc/hotplug/scsi.agent should load the sg module.
Comment 3 Bill Nottingham 2005-03-22 22:55:23 EST
This should be fixed in hotplug-2004_09_23-3.
Comment 4 Aleksandar Milivojevic 2005-04-15 10:22:24 EDT
*** Bug 154857 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.