Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1515462

Summary: db2ldif with-s export fails with error -9 , DS console export broken
Product: Red Hat Directory Server Reporter: Marc Sauton <msauton>
Component: Command Line UtilitiesAssignee: mreynolds
Status: CLOSED WORKSFORME QA Contact: Viktor Ashirov <vashirov>
Severity: urgent Docs Contact:
Priority: high    
Version: 10.0CC: apeddire, mreynolds, mrichter, pasik, tmihinto
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-09 15:28:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marc Sauton 2017-11-20 20:18:33 UTC
Description of problem:

regression:

The db2ldif -s option seem to be rejected by the server:

db2ldif.pl  -D "cn=directory manager" -w password -r -a /tmp/m1.userroot.replica.export.ldif -s dc=example,dc=com
Exporting to ldif file: /tmp/m1.userroot.replica.export.ldif
ldap_add: Bad parameter to an ldap routine (-9)
Failed to add task entry "cn=export_2017_11_20_20_21_16, cn=export, cn=tasks, cn=config" error (247)

but -n works as usual:

db2ldif.pl  -D "cn=directory manager" -w password -r -a /tmp/m1.userroot.replica.export.ldif -n userroot
Exporting to ldif file: /tmp/m1.userroot.replica.export.ldif
Successfully added task entry "cn=export_2017_11_20_20_21_38, cn=export, cn=tasks, cn=config"

In the RHDS-10 console, an export task fails with error -9 in a pop-up window, task not created, nothing is exported.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.4 (Maipo)
389-ds-base-1.3.6.1-21.el7_4.x86_64
redhat-idm-console-10.1.0-2.el7dsrv.x86_64
idm-console-framework-1.1.17-4.el7dsrv.noarch


How reproducible:
always


Steps to Reproduce:
1. Have RHEL-7 and RHDS-10 setup
2. db2ldif.pl  -D "cn=directory manager" -w password -r -a /tmp/m1.userroot.replica.export.ldif -s dc=example,dc=com
3.

Actual results:


Expected results:


Additional info: