Bug 151548 - S3 ProSavage KM133 hates Alternate Console
S3 ProSavage KM133 hates Alternate Console
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-19 00:33 EST by Carl Flarity
Modified: 2015-01-04 17:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 18:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Flarity 2005-03-19 00:33:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When I invoke an alternate console with Ctrl+Alt+F1 (etc.) I see garbage on video monitor. If I change the video adapter driver from "S3 ProSavage KM133" to "VESA (generic video driver)" it works fine. My monitor is a Sony LCD but I saw the same problem with a conventional CRT monitor when I swapped it in. 

Note that "Red Hat 3 Professional Workstation" also has a buggy "S3 ProSavage KM133" driver but with different symptoms that is fixed by switching to VESA. The "S3 ProSavage KM133" driver in "Red Hat 4 Professional Workstation" works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select "S3 ProSavage KM133" video driver.
2. Invoke alternate console with Ctrl+Alt+F1
3.
  

Additional info:
Comment 1 Dave Jones 2005-06-27 19:14:31 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 2 Junior 2005-06-29 18:01:17 EDT
My name is Junior.  I am Brazilian and I forgive my English.  The problem still
exists in the final version.
Comment 3 Dave Jones 2005-07-15 17:04:58 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 hary 2005-08-05 18:37:33 EDT
(In reply to comment #3)
> [This comment has been added as a mass update for all FC4 kernel bugs.
>  If you have migrated this bug from an FC3 bug today, ignore this comment.]
> 
> Please retest your problem with todays 2.6.12-1.1398_FC4 update.

When I use s3virge driver with my S3 ViRGE/DX card and switch to text console I
get screen corrupted (nothing can be read, characters are visible as blocks of
vertical strokes).

I installed all the newest xorg-*-6.8.2-37.i386.rpm RPMs and nothing changed.

I also tried some older s3virge drivers (which I was using in other distros):
from FC1 (didn't work in FC4, crashed), from FC3 and aurox (based on FC3, I
guess). The latter two work, but after switching to text console screen is
destroyed.

This means that problem is related to FC4, not to driver itself.

Vesa driver works ok, but with vertical refresh 60Hz it is useless.

Additional info: after swithing to text console (using vesa driver in FC4)
unicode characters are not displayed correctly and keyboard delay is changed to
1000ms. These bugs persist since FC1.

Comment 5 M.Seiler 2005-08-11 09:07:09 EDT
I have the same garbage problem with a ASUS L8400C laptop. The display driver 
is "S3 Savage/MX". If I switch to VESA all works fine.
Comment 6 M.Seiler 2005-08-11 09:08:33 EDT
Sorry I forget some infos.... On fc3 all works fine with the savage driver. 
The problem starts today after I upgraded to fc4.
Comment 7 Dave Jones 2005-08-11 18:37:47 EDT

*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.