Bug 151556 - bindkey does not bind to F1 key using syntax from info page
bindkey does not bind to F1 key using syntax from info page
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-03-19 08:27 EST by Robin Green
Modified: 2008-02-26 12:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-26 12:21:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-03-19 08:27:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
The bindkey command does not work for the F1 key in the way documented in the info pages for screen (see "info screen").

Not sure whether this is a documentation bug or a code bug.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start screen
2. Ctrl+A c Ctrl+A c (to create some more screens)
3. Ctrl+A
4. Type ":bindkey -k k1 select 1" (without the quotes) and press ENTER
5. Press the F1 key  

Actual Results:  The command was accepted, but nothing happened when I pressed F1.

Expected Results:  Should switch to screen #1

Additional info:

Terminal emulator is konsole from kdebase-3.4.0-1. Same problem occurs with xterm.
Comment 1 Petr Rockai 2005-04-27 06:08:31 EDT
Erm, worksforme. Please try to reproduce again and make sure you have no typos  
or something in the command :). Also, note that screen 0 != screen 1. 
Comment 2 Robin Green 2005-04-27 10:24:36 EDT
No, still doesn't work. I am typing exactly: ":bindkey -k k1 select 1" - are you?
Comment 3 Petr Rockai 2006-01-17 11:46:12 EST
Note that not all terminals pass the key to screen as they should. However, in 
both linux tty and (some versions of) xterm this works as expected (unlike eg. 
konsole, which apparently catches the key or sends wrong key sequence (it is 
supposed to act like xterm)). I haven't tried in gnome-terminal. 
However, you are right in that the xterm as shipped with fedora core causes 
problems with this. Could you please at least confirm this works in a linux 
tty so we can rule out other causes (apart from the suspected terminal 
Maybe you could try with different TERM settings, but i didn't generate much 
success either. It could be either terminfo or the terminals themselves that 
are at fault though. 
Comment 4 Robin Green 2006-01-18 09:07:57 EST
> Could you please at least confirm this works in a linux 
> tty so we can rule out other causes

Yes, it does work when I do ctrl+alt+f1 and try it there.
Comment 5 Marcela Mašláňová 2006-11-15 08:43:26 EST
It's feature of your KDE/Gnome/Xfce/... I'm using Xfce with multi-gnome. After I
pressed F1, it'll open help in firefox - help is for current program, in this
case help for screen.
So you could change your button shortcuts.
Comment 6 Robin Green 2006-11-15 08:59:01 EST
It still doesn't work in xterm, and I don't see any keyboard shortcut for F1 in
gnome-control-center. Please consider this bug as only about xterm since the
other cases have been explained.
Comment 7 John Poelstra 2007-11-19 11:09:24 EST
I reproduced problem with latest version in Fedora 8

 $ rpm -qi screen
Name        : screen                       Relocations: (not relocatable)
Version     : 4.0.3                             Vendor: Fedora Project
Release     : 8.fc8                         Build Date: Fri 24 Aug 2007 03:37:18
Install Date: Sun 04 Nov 2007 07:58:30 PM PST      Build Host:
Group       : Applications/System           Source RPM: screen-4.0.3-8.fc8.src.rpm
Size        : 790133                           License: GPLv2+
Signature   : DSA/SHA1, Thu 25 Oct 2007 05:25:34 AM PDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
URL         : http://www.gnu.org/software/screen
Summary     : A screen manager that supports multiple logins on one terminal
Description :
The screen utility allows you to have multiple logins on just one
terminal. Screen is useful for users who telnet into a machine or are
connected via a dumb terminal, but want to use more than just one

Install the screen package if you need a screen manager that can
support multiple logins on one terminal.
Comment 8 Miroslav Lichvar 2008-02-26 12:21:04 EST
The default config was using wrong sequences for xterm's F1-F4, should be fixed
in screen-4.0.3-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.