Bug 151565 - gfortran should build netcdf
Summary: gfortran should build netcdf
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: netcdf   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ed Hill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-19 21:17 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-06 18:21:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Dumas 2005-03-19 21:17:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.2) Gecko/20040804

Description of problem:
There is a buildrequire for gcc-g77 although netcdf can also be built with gcc-gfortran. I don't know how this could be solved (is there a possibility to do a buildrequire gcc-g77 or gcc-gfortran?).

Version-Release number of selected component (if applicable):
netcdf-3.6.0-0.2.beta6

How reproducible:
Always

Steps to Reproduce:
1. install gcc-gfortran but not gcc-g77
2. download netcdf srpm, and do a rpmbuild
3. 
  

Actual Results:  An error about missing build require, gcc-g77 is required.

Expected Results:  A build.

Additional info:

After I change the buildrequires line to

BuildRequires:  gcc-gfortran

and comment out the FC setting:

#export FC="g77"

the build seems file.

Comment 1 Ed Hill 2005-04-06 18:21:26 UTC
Thank you for the bug report.  It took a while for me to get
access to a machine running all the latest devel packages to 
confirm.  But in any case, its now fixed in Fedora Extras 
CVS.

Comment 2 Patrice Dumas 2005-04-07 22:08:48 UTC
It works for me. It seems that gcc-g77 won't be shipped, so it is not a real
issue if the build requirement is not gcc-g77 or gcc-gfortran, but only
gcc-gfortran. Moreover this could be imposible to achieve.


Note You need to log in before you can comment on or make changes to this bug.