Bug 151569 - /lib/cpp fails sanity check make sometimes fails
/lib/cpp fails sanity check make sometimes fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-19 17:57 EST by Kevin Olemoh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 02:37:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Olemoh 2005-03-19 17:57:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When trying to compile xine-lib 1.0 the configure script fails various checks for c++ g++ cXX etc finally failing with the error message /lib/cpp fails sanity check.  Anything that might call on things like g++ for example libebml also fail so this is definetly not isolated to Xine-lib.

Version-Release number of selected component (if applicable):
gcc-4.0,0-0.34

How reproducible:
Sometimes

Steps to Reproduce:
1.Run ./configure or in some cases make
2.Wait for g++ or cpp related failure message
3.
  

Actual Results:  Builds of Xine-lib and libebml failed I suspect because of something in glibc-headers.

Expected Results:  ./configure and make should have built the nessecary files as normal.

Additional info:
Comment 1 Kevin Olemoh 2005-03-19 17:59:15 EST
Some builds do complete successfully I was able to compile Libmad without
incident for example.
Comment 2 Jakub Jelinek 2005-03-20 09:54:13 EST
Please provide details.  What exact command the configure script is running, what
error messages do you get.
Comment 3 Kevin Olemoh 2005-03-26 17:39:54 EST
Well after letting it sit for a week because I got busy with other things and
doing a clean install this particular problem I was having seems to have already
been resolved.  I'll try to keep you posted if anything else wierd pops up.

Note You need to log in before you can comment on or make changes to this bug.