Bug 1515878 - Short names discovery broken on v3.7.9 server
Summary: Short names discovery broken on v3.7.9 server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 14:26 UTC by Fabiano Franz
Modified: 2018-01-23 17:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Categories like 'all' were moved to the server but some of them were only moved after the upstream cut for the rebase, causing an incomplete list of resources. Consequence: Some resources could not be found in 'oc get all' and some other 'oc get' calls. Fix: the remaining upstream commits were picked to include all needed resources. Result: 'oc get all' and the other problematic calls were fixed.
Clone Of:
Environment:
Last Closed: 2018-01-23 17:58:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC

Description Fabiano Franz 2017-11-21 14:26:39 UTC
Description of problem: 'oc logs sts/mysts' fails with the error below instead of listing the statefulsets or "No resource found":

oc logs -c prom-proxy sts/prometheus --loglevel=6
F1120 11:12:06.569506   76005 helpers.go:120] the server doesn't have a resource type "sts"

'oc logs statefulsets/mysts' works correctly. 


Version-Release number of selected component (if applicable): It works correctly on ca-central-1, but not on free-stg. So this probably regressed between 178 OSE and RC OSE.

How reproducible: Not always, meaning this could be related to caching.

Comment 1 Fabiano Franz 2017-11-21 14:27:48 UTC
Adding Clayton which could add more info.

Comment 2 Fabiano Franz 2017-11-21 14:34:14 UTC
Could you help trying to reproduce this one? Clayton noticed it first but I was yet unable to reproduce. 'oc' used is always the latest version.

Comment 3 Fabiano Franz 2017-11-21 14:35:38 UTC
Adding some more folks since it's not yet clear if this is client-side or related to discovery and the shortNames field.

Comment 4 David Eads 2017-11-21 19:09:41 UTC
I built openshift/origin:release-3.7 and hit discovery.  Got back

```json
    {
      "name": "statefulsets",
      "singularName": "",
      "namespaced": true,
      "kind": "StatefulSet",
      "verbs": [
        "create",
        "delete",
        "deletecollection",
        "get",
        "list",
        "patch",
        "update",
        "watch"
      ],
      "shortNames": [
        "sts"
      ],
      "categories": [
        "all"
      ]
    }
```

It looks correct to me.

Comment 5 Clayton Coleman 2017-11-21 19:15:59 UTC
https://github.com/openshift/origin/issues/17411

master against 3.7 server, svc not in all

Comment 6 Fabiano Franz 2017-11-21 19:18:35 UTC
David, do you see it for services? I built openshift/origin:release-3.7 and see shortNames and categories for statefulsets, but not for services for example. Likely others.

Comment 7 Fabiano Franz 2017-11-21 19:20:57 UTC
BTW the same issue happens with `kubectl` master against openshift/origin:release-3.7 server.

Comment 8 David Eads 2017-11-21 20:17:03 UTC
There was a bug for services.  I fixed it in kube, might have been 3.8 though.

Comment 9 Xingxing Xia 2017-11-22 03:32:48 UTC
(In reply to Fabiano Franz from comment #2)
> Could you help trying to reproduce this one? Clayton noticed it first but I
> was yet unable to reproduce. 'oc' used is always the latest version.
Tried 3.7.9 oc against free-stg (3.7.9), I didn't reproduce it. But I found possible cause: try oc version several times, server version is unstable, seems some masters on free-stg were not restarted after upgrade[1]:
$ oc version
oc v3.7.9
...
Server https://api.free-stg.openshift.com:443
openshift v3.6.173.0.49
kubernetes v1.6.1+5115d708d7

$ oc version
oc v3.7.9
...
Server https://api.free-stg.openshift.com:443
openshift v3.7.9
kubernetes v1.7.6+a08f5eeb62

Fabiano, it is possible cause, because I checked 3.7 oc against 3.6 OCP can reproduce 'the server doesn't have a resource type "sts"'

[1] Adding Abhishek, default Assignee of Website, in CC' list for confirming to help check and restart them, thanks

Comment 10 Fabiano Franz 2017-11-22 14:57:20 UTC
> There was a bug for services.  I fixed it in kube, might have been 3.8 though.

David, picking the fix for services into 3.7 in  https://github.com/openshift/ose/pull/931.

Comment 11 Fabiano Franz 2017-12-05 20:17:15 UTC
Will be in the next 3.7.

Comment 16 errata-xmlrpc 2018-01-23 17:58:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.