Bug 1516233 - Freeradius produce avc: denied { search }
Summary: Freeradius produce avc: denied { search }
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5-Alt
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 10:38 UTC by Jaroslav Aster
Modified: 2018-10-30 10:01 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-207.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:01:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:01:53 UTC

Description Jaroslav Aster 2017-11-22 10:38:03 UTC
Description of problem:

Freeradius produces avc.

---
time->Thu Nov 16 14:28:27 2017
type=PROCTITLE msg=audit(1510860507.989:1108): proctitle=2F7573722F7362696E2F72616469757364002D43
type=SYSCALL msg=audit(1510860507.989:1108): arch=c000003e syscall=2 success=no exit=-13 a0=7ff0d78cef18 a1=80000 a2=1b6 a3=24 items=0 ppid=1 pid=2692 auid=4294967295 uid=0 gid=95 euid=95 suid=0 fsuid=95 egid=95 sgid=95 fsgid=95 tty=(none) ses=4294967295 comm="radiusd" exe="/usr/sbin/radiusd" subj=system_u:system_r:radiusd_t:s0 key=(null)
type=AVC msg=audit(1510860507.989:1108): avc:  denied  { search } for  pid=2692 comm="radiusd" name="net" dev="proc" ino=9842 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir permissive=0


Version-Release number of selected component (if applicable):

selinux-policy-3.13.1-180.el7

How reproducible:

100%


Steps to Reproduce:

Run test /CoreOS/freeradius/Sanity/check-ipaddr-ipv4addr-and-ipv6addr-address-usage.


Actual results:

Freeradius produces avc.


Expected results:

Freeradius does not produce avc.

Comment 1 Milos Malik 2018-05-02 09:35:35 UTC
Caught in enforcing mode:
----
type=PROCTITLE msg=audit(05/02/2018 05:29:57.984:327) : proctitle=/usr/sbin/radiusd -C 
type=SYSCALL msg=audit(05/02/2018 05:29:57.984:327) : arch=x86_64 syscall=open success=no exit=EACCES(Permission denied) a0=0x7f67f36d5098 a1=O_RDONLY|O_CLOEXEC a2=0x1b6 a3=0x24 items=0 ppid=1 pid=24434 auid=unset uid=root gid=radiusd euid=radiusd suid=root fsuid=radiusd egid=radiusd sgid=radiusd fsgid=radiusd tty=(none) ses=unset comm=radiusd exe=/usr/sbin/radiusd subj=system_u:system_r:radiusd_t:s0 key=(null) 
type=AVC msg=audit(05/02/2018 05:29:57.984:327) : avc:  denied  { search } for  pid=24434 comm=radiusd name=net dev="proc" ino=8802 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir permissive=0 
----

Caught in permissive mode:
----
type=PROCTITLE msg=audit(05/02/2018 05:33:58.004:363) : proctitle=/usr/sbin/radiusd -C 
type=SYSCALL msg=audit(05/02/2018 05:33:58.004:363) : arch=x86_64 syscall=open success=yes exit=6 a0=0x7f43d61d3098 a1=O_RDONLY|O_CLOEXEC a2=0x1b6 a3=0x24 items=0 ppid=1 pid=27991 auid=unset uid=root gid=radiusd euid=radiusd suid=root fsuid=radiusd egid=radiusd sgid=radiusd fsgid=radiusd tty=(none) ses=unset comm=radiusd exe=/usr/sbin/radiusd subj=system_u:system_r:radiusd_t:s0 key=(null) 
type=AVC msg=audit(05/02/2018 05:33:58.004:363) : avc:  denied  { open } for  pid=27991 comm=radiusd path=/proc/sys/net/ipv6/conf/all/disable_ipv6 dev="proc" ino=8863 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file permissive=1 
type=AVC msg=audit(05/02/2018 05:33:58.004:363) : avc:  denied  { read } for  pid=27991 comm=radiusd name=disable_ipv6 dev="proc" ino=8863 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file permissive=1 
type=AVC msg=audit(05/02/2018 05:33:58.004:363) : avc:  denied  { search } for  pid=27991 comm=radiusd name=net dev="proc" ino=8802 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir permissive=1 
----
type=PROCTITLE msg=audit(05/02/2018 05:33:58.004:364) : proctitle=/usr/sbin/radiusd -C 
type=SYSCALL msg=audit(05/02/2018 05:33:58.004:364) : arch=x86_64 syscall=fstat success=yes exit=0 a0=0x6 a1=0x7ffe9e049070 a2=0x7ffe9e049070 a3=0x0 items=0 ppid=1 pid=27991 auid=unset uid=root gid=radiusd euid=radiusd suid=root fsuid=radiusd egid=radiusd sgid=radiusd fsgid=radiusd tty=(none) ses=unset comm=radiusd exe=/usr/sbin/radiusd subj=system_u:system_r:radiusd_t:s0 key=(null) 
type=AVC msg=audit(05/02/2018 05:33:58.004:364) : avc:  denied  { getattr } for  pid=27991 comm=radiusd path=/proc/sys/net/ipv6/conf/all/disable_ipv6 dev="proc" ino=8863 scontext=system_u:system_r:radiusd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file permissive=1 
----

Comment 7 errata-xmlrpc 2018-10-30 10:01:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.