Bug 151638 - vsftpd crashes on login
vsftpd crashes on login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 05:57 EST by P Fudd
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 03:36:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Fudd 2005-03-21 05:57:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
220 (vsFTPd 2.0.3)

USER someuser

331 Please specify the password.

PASS somepass

530 Login incorrect.

500 OOPS: vsf_sysutil_recv_peek: no data

500 OOPS: child died

grep someuser /etc/passwd:
someuser:x:556:556:guest acct:/var/www/html/someuser/./:/etc/ftponly

The shell /etc/ftponly is not in /etc/shells



Version-Release number of selected component (if applicable):
vsftpd-2.0.3-pre2, vsftpd-2.0.1-5

How reproducible:
Always

Steps to Reproduce:
1. Create a user with a password and a shell that doesn't exist in /etc/shells
2. Try to log in.
3. 
  

Actual Results:  530 Login incorrect.
500 OOPS: vsf_sysutil_recv_peek: no data
500 OOPS: child died

Expected Results:  Successful login.

Additional info:

It's a mystery to me why a bad shell should cause such a hiccup.  I'd expect a nice (or mysterious) error message for the user and a clear error message to syslog.
Comment 1 Chris Evans 2005-03-22 17:30:52 EST
Can't reproduce any vsftpd problem.
500 OOPS: vsf_sysutil_recv_peek: no data usually means that the FTP client
just disconnects suddenly. What FTP client is in use here?
Comment 2 P Fudd 2005-07-31 05:02:22 EDT
Initially I discovered the problem using Mozilla.  Then I tried the regular
'ftp' command.  I wound up using 'telnet' to demonstrate the problem to myself.

It's been a while, and I've reformatted that system since then, but I'm thinking
it might have been a problem with selinux.  Try adding a user to the password
and shadow files with 'vi', don't tell selinux about the user, and see if that
causes it.  If not, then I guess this bug has vanished.

Sorry for the long delay!
Comment 3 Kumphanart Dansiri 2005-09-22 05:49:20 EDT
The problem will go away as soon as you disable selinx.  I would like the work
around for selinux enabled.
:)
Comment 4 Radek Vokal 2006-02-07 07:04:30 EST
If it's a selinux issue, can you post the vsftpd related lines from
/var/log/audit.log and /var/log/messages here? 
Comment 5 Penelope Fudd 2006-02-08 03:33:18 EST
Ouchie.  I reformatted that system in July of last year and haven't experienced
the problem since.  I just tried recreating it on my current system (FC4), and
couldn't.

I guess this bug is now close-able; sorry!
Comment 6 Radek Vokal 2006-02-08 03:36:19 EST
No problem, it took me quite a long time to get back to this bug :) I'm closing
it as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.