Bug 1516397 - the validator ceph-ansible-installed.yaml generates a warning, and the GUI doesn't show the warning
Summary: the validator ceph-ansible-installed.yaml generates a warning, and the GUI do...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Florian Fuchs
QA Contact: Udi
URL:
Whiteboard:
: 1526457 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 14:34 UTC by Udi
Modified: 2018-06-27 13:40 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-8.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 521849 None master: MERGED tripleo-validations: Remove yum warning in ceph-ansible validation (I17b9b8340a6127b2982e500f1d4bd907f42af518) 2018-03-29 16:02:39 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:40:23 UTC

Description Udi 2017-11-22 14:34:25 UTC
Description of problem:
I installed ceph-ansible on my undercloud, and ran the validaotr. The validator resulted with a warning, which only had the word "warning" in it and no additional information. To the GUI user, it is not clear whether ceph-ansible is installed or not.

When I ran the validator from the command line, I was able to see the warning:
 [WARNING]: Consider using yum module rather than running yum


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-4.el7ost.noarch
openstack-tripleo-validations-7.4.2-1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install ceph-ansible.
2. Run the validator from the GUI
3. Run the validator from the command line:
ANSIBLE_RETRY_FILES_ENABLED=false ansible-playbook -i /usr/bin/tripleo-ansible-inventory /usr/share/openstack-tripleo-validations/validations/ceph-ansible-installed.yaml 


Actual results:
Validator generates a warning. The GUI doesn't display the warning and only from the CLI you see what kind of an error it is.


Expected results:
No Warnings. If there are warnings - the GUI should show them also.

Comment 1 Udi 2017-11-22 14:34:51 UTC
The fix is here: https://review.openstack.org/#/c/521849/

Comment 3 Gaël Chamoulaud 2017-12-11 09:17:45 UTC
A fix for that issue has been merged in stable/master and stable/pike

Comment 4 Alexander Chuzhoy 2017-12-18 14:44:05 UTC
*** Bug 1526457 has been marked as a duplicate of this bug. ***

Comment 8 Udi 2018-04-18 08:06:54 UTC
Verified:
openstack-tripleo-validations-8.4.0-1.el7ost.noarch
openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 10 errata-xmlrpc 2018-06-27 13:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.