Bug 151645 - cups does not respect lpoptions settings
cups does not respect lpoptions settings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 151644 155323 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 07:45 EST by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.0.2-13.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 12:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printconf xml output (6.08 KB, text/plain)
2005-04-12 10:20 EDT, Adam Pribyl
no flags Details
/usr/share/foomatic/db/source/driver/Postscript.xml (23.45 KB, text/plain)
2005-04-12 13:22 EDT, Tim Waugh
no flags Details

  None (edit)
Description Adam Pribyl 2005-03-21 07:45:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8b) Gecko/20050217

Description of problem:
Even thought I have set number-up=2 in lpoptions for printer HP2300dsdd (set throught printconf-gui):

# more /etc/cups/lpoptions
Default HP2300 page-bottom=86 cpi=12 page-right=57 page-left=57 page-top=72 scaling=100 lpi=7 wrap=true
Dest HP2300dsdd cpi=12 lpi=7 number-up=2 page-bottom=86 page-left=57 page-right=57 page-top=72 scaling=100 wrap=true

It is not printing two pager per one paper side.

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5

How reproducible:
Always

Steps to Reproduce:
1.open printconf-gui
2.setup a new printer queue and add queue option number-up=2
3.apply and try to print trough this queue
  

Actual Results:  There is still only one page per printed paper side.

Expected Results:  There should be to pages of text at one printer paper side.

Additional info:

Also other options seems to be ignored.
Comment 1 Adam Pribyl 2005-03-21 07:47:42 EST
*** Bug 151644 has been marked as a duplicate of this bug. ***
Comment 2 Adam Pribyl 2005-04-11 06:58:37 EDT
After latest update of foomatic I am not able to print even duplex. I removed
all of the printers and settings in /etc and newly created jetdirect queues,
tried using PS driver and/or driver for the printer - non of them are printing
duplex or number-up 2 pages. The printer is now also printing blank sheet at the
end of every job.
Comment 3 Tim Waugh 2005-04-11 07:03:04 EDT
Please attach the output of 'printconf-tui --Xexport'.  Thanks.
Comment 4 Adam Pribyl 2005-04-12 10:20:21 EDT
Created attachment 113018 [details]
printconf xml output
Comment 5 Tim Waugh 2005-04-12 12:18:03 EDT
Okay, looks like this is because of this change to Postscript.xml:

revision 3.38
date: 2004/12/03 12:36:31;  author: till;  state: Exp;  lines: +1 -1
Added IEEE 1284 IDs and PPD links, fixed renderer command line of
"Postscript" for non-bash.

Comment 6 Tim Waugh 2005-04-12 13:22:15 EDT
Created attachment 113038 [details]
/usr/share/foomatic/db/source/driver/Postscript.xml

Please save this attachment and copy it to:

  /usr/share/foomatic/db/source/driver/Postscript.xml

Does this solve the problem?
Comment 7 Adam Pribyl 2005-04-14 09:29:16 EDT
I spent another few hours digging around. For sure this Postscript.xml does not
change anything (diff to version I had say only difference is in /usr/bin/prinf
instead only printf.)

6c6
<    <prototype>level=%D; /usr/bin/printf &quot;%%!\n%%%% %%%%\n%C&quot;; if [
$level -gt 0 ]; then if [ $level -lt 99 ]; then level=&quot;
-dLanguageLevel=$level&quot;; else level=&quot;&quot;; fi; gs -q -dPARANOIDSAFER
-dNOPAUSE -dBATCH -sDEVICE=pswrite$level%A%Z -sOutputFile=- -; else cat;
fi</prototype>
---
>    <prototype>level=%D;          printf &quot;%!\n%%%% %%%%\n%C&quot;; if [
$level -gt 0 ]; then if [ $level -lt 99 ]; then level=&quot;
-dLanguageLevel=$level&quot;; else level=&quot;&quot;; fi; gs -q -dPARANOIDSAFER
-dNOPAUSE -dBATCH -sDEVICE=pswrite$level%A%Z -sOutputFile=- -; else cat;
fi</prototype>

However I found, that troubles are variing with apps. 
OOo is completely ignoring queue settings even thought it says it is using
cups:HP2300dsddHP, prints singleside single page and blank sheet at the end of
job. (Also options in OOo Print preferences are set to use Long Edge duplex..)

Mozilla 1.7.6 is printing singleside but lpoptions seems correct (2 pages per side).

Evolution seems to be only app printing double side (which is strange), however
is not printing two pages per side. Does not print blank page.

(all distribution apps, no special settings made)

mozilla-i686-pc-linux-gnu-gtk2+xft-1.8b1 has same problems as OOo, when printing
trough queue HP2300dsddHP, however has also printing output "Postscript default"
which prints single side, two pages per sheet but blank sheet at the end of page.

OOo2b has another problem which is better to not describe here..

(both non-fedora apps)

I am starting to think about ghost (not script) in the system. 
If you feel this is unresolvable, as it is not a systematical, but applicational
problem, please close the bug.
Comment 8 Tim Waugh 2005-04-14 10:11:15 EDT
The printf change is indeed small -- but vital.  Not only is a different printf
used (the /usr/bin/printf differs from the bash builtin), but there was a
missing '%' at the beginning of the format.

Please try this:

Become root: su -
Run this command: /usr/sbin/printconf-backend --force-rebuild

Do you notice any difference now?
Comment 9 Adam Pribyl 2005-04-14 12:09:39 EDT
Yep, duplex is working now, no blank pages! Great! What --force-rebuild does?
Only lpotions are still ignored when printing from OOo. (I am where I was before
update - in times when I reported this bug.) When I take a look into
/var/spool/cups/ into job file, I do not see number-up option there. How's that
possible? 
Comment 10 Tim Waugh 2005-04-14 12:24:07 EDT
printconf-backend rebuilds the CUPS queues based on its configuration.  It takes
the PPD generated by foomatic and puts it in the right place.  The PPD needed
remaking after the XML file was updated.

I don't know why OpenOffice.org is behaving differently.
Comment 11 Tim Waugh 2005-04-20 10:06:10 EDT
*** Bug 155323 has been marked as a duplicate of this bug. ***
Comment 12 Adam Pribyl 2005-04-20 10:21:23 EDT
(In reply to comment #10)
 
> I don't know why OpenOffice.org is behaving differently.

Actually it is not a mather of only OOo (1.1.x). Lot of other apps also does not
print with number-up=2, e.g. Evolution.
Comment 13 Tim Waugh 2005-04-20 12:42:10 EDT
Taking this issue to be the Postscript.xml bug -- please open separate bugs for
any further issues.  Thanks.
Comment 14 Wayne Schuller 2005-04-21 07:49:46 EDT
oh wow this is really really good.

I was pulling my hair out over this bug.

I was not getting any duplex settings respected.

But I have applied the foomatic errata and now it appears to work again.

You should put a better errata description than (Fix Postscript driver).

This bug was sooo annoying. Once you get used to duplex it is impossible to go back!

Thank you for fixing this bug. Thank you Adam for your great bug reporting. I
would not know a thing about all the cups magic that happens.

Note You need to log in before you can comment on or make changes to this bug.