Bug 1516531 (CVE-2017-15923) - CVE-2017-15923 konversation: Denial of service while parsing IRC color formatting codes
Summary: CVE-2017-15923 konversation: Denial of service while parsing IRC color format...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2017-15923
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1516532 1516533
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 20:35 UTC by Pedro Sampaio
Modified: 2019-09-29 14:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:31:52 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2017-11-22 20:35:29 UTC
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.

Upstream patch:

https://cgit.kde.org/konversation.git/commit/?h=1.7&id=6a7f59ee1b9dbc6e5cf9e5f3b306504d02b73ef0

Comment 1 Pedro Sampaio 2017-11-22 20:35:56 UTC
Created konversation tracking bugs for this issue:

Affects: epel-all [bug 1516533]
Affects: fedora-all [bug 1516532]

Comment 2 Fedora Update System 2017-11-28 16:20:11 UTC
konversation-1.7.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 3 Fedora Update System 2017-11-28 17:32:47 UTC
konversation-1.7.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Product Security DevOps Team 2019-06-08 03:31:52 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.