Bug 151661 - G5 fan constantly runs (very noisy)
G5 fan constantly runs (very noisy)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks: fedora-ppc FC4Target
  Show dependency treegraph
 
Reported: 2005-03-21 10:30 EST by Andrew Cagney
Modified: 2014-03-16 22:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2005-03-21 10:30:17 EST
Description of problem:

The modules responsible for managing the fan aren't loaded by default.  They are:

i2c_core.ko
i2c_keywest.ko
therm_pm72.ko

(thanks to dwmw2 for providing these)
Comment 1 Bill Nottingham 2005-03-22 23:10:25 EST
How would it be known that these are needed?
Comment 2 Andrew Cagney 2005-03-23 16:40:01 EST
um, are you asking me?
Comment 3 Bill Nottingham 2005-03-23 17:18:19 EST
Asking anyone who might have an idea, yes. Cc'ing some of the PPC folks.
Comment 4 Jakub Jelinek 2005-04-11 07:22:40 EDT
Maybe
grep -q '^machine.*:.*PowerMac7,[23]' /proc/cpuinfo
?
Note i2c_core doesn't need to be loaded manually, it is a dependency of
both the other modules.
Alternatively, look for /proc/device-tree node where
/proc/device-tree/.../compatible contains fcu\0:
hexdump /proc/device-tree/u3/i2c/fan/compatible
0000000 6663 7500
0000004

BTW, If there is a fan node in device-tree and is */compatible with
adt7460 or adt7467, therm_adt746x module should be used instead.

This noise difference is huge, so FC4 really should have this fixed somehow.
Comment 5 Bill Nottingham 2005-04-11 15:54:04 EDT
Which of keywest & the thermal module do you need, or both?
Comment 6 Andrew Overholt 2005-04-12 13:54:46 EDT
Both.
Comment 7 Bill Nottingham 2005-04-16 00:01:36 EDT
Jakub: are there any fan nodes in the device-tree for the pm72?
Comment 8 Bill Nottingham 2005-04-16 00:02:42 EDT
Woops, I can't read. Don't mind me.
Comment 9 Bill Nottingham 2005-04-16 00:10:11 EDT
Note that we don't build therm_adt746x or therm_windtunnel. Should we?
Comment 10 Bill Nottingham 2005-04-16 00:48:29 EDT
therm_adt745x/therm_pm72 should be handled in kudzu-1.1.112-1/initscripts-8.08-2.
Comment 11 Orion Poplawski 2005-05-17 11:27:22 EDT
fc4test3 on mac mini doesn't load any therm modules.  In fact, no longer see
therm_pm72, though I don't have any idea which module the mini needs.

[root@mini ~]# lsmod | grep i2c
i2c_keywest            13828  0

[root@mini ~]# dmesg | grep  -i i2c
Found KeyWest i2c on "uni-n", 2 channels, stepping: 4 bits
Found KeyWest i2c on "mac-io", 1 channel, stepping: 4 bits

[root@mini ~]# lsmod | grep therm

[root@mini ~]# find /lib/modules/ -name therm\*.ko
/lib/modules/2.6.11-1.1286_FC4/kernel/drivers/macintosh/therm_adt746x.ko
/lib/modules/2.6.11-1.1286_FC4/kernel/drivers/macintosh/therm_windtunnel.ko

[root@mini ~]# modprobe therm_adt746x
FATAL: Error inserting therm_adt746x
(/lib/modules/2.6.11-1.1286_FC4/kernel/drivers/macintosh/therm_adt746x.ko): No
such device

[root@mini ~]# modprobe therm_windtunnel
FATAL: Error inserting therm_windtunnel
(/lib/modules/2.6.11-1.1286_FC4/kernel/drivers/macintosh/therm_windtunnel.ko):
No such device

[root@mini ~]# ls /lib/modules/2.6.11-1.1286_FC4/kernel/drivers/macintosh/
therm_adt746x.ko  therm_windtunnel.ko
Comment 12 Colin Charles 2005-05-18 00:55:44 EDT
(In reply to comment #11)
> fc4test3 on mac mini doesn't load any therm modules.  In fact, no longer see
> therm_pm72, though I don't have any idea which module the mini needs.
> 
> [root@mini ~]# modprobe therm_adt746x
> [root@mini ~]# modprobe therm_windtunnel
> FATAL: Error inserting therm_windtunnel

None of these will work, that being therm_pm72, therm_adt746x, or
therm_windtunnel on the Mac mini. So kudzu is being right in *not* detecting
them. Please open up another bug for this, thanks

Now, G5 users, does the comment #10 apply, and is there sane fan control now?
cagney, dwmw2, overholt, jakub?
Comment 13 David Woodhouse 2005-05-18 01:48:34 EDT
(In reply to comment #12)
> Now, G5 users, does the comment #10 apply, and is there sane fan control now?
> cagney, dwmw2, overholt, jakub?

Not sure. It's working on my G5 but because I set it up manually -- I that
machine is mostly still running FC3 and hasn't been reinstalled since the middle
of last year.

I'm wondering if we should build these into the kernel instead of as modules;
that would make the fans work during the install too.
Comment 14 Andrew Overholt 2005-05-18 09:22:52 EDT
(In reply to comment #12)
> Now, G5 users, does the comment #10 apply, and is there sane fan control now?
> cagney, dwmw2, overholt, jakub?

I haven't re-installed this machine since test2.  I need to update my iBook G4
so I'll install that and then use that while I re-install this machine (G5).

(In reply to comment #11)
> I'm wondering if we should build these into the kernel instead of as modules;
> that would make the fans work during the install too.

I would like this.

Comment 15 Colin Charles 2005-05-18 10:27:06 EDT
(In reply to comment #14)
> (In reply to comment #11)
> > I'm wondering if we should build these into the kernel instead of as modules;
> > that would make the fans work during the install too.
> 
> I would like this.

As I said to dwmw2 on irc, we don't build ext3 into the kernel, what are our
chances of getting thermal control built in? ;-)
Comment 16 Bertrand 2005-06-25 14:09:54 EDT
I've just installed FC4 on a brand new G5 2*2.0 (PowerMac7,3) and the bug is
still here.

The i2c_core and i2c_keywest drivers seems to be now in the kernel, but the
therm_pm72 isn't loaded.

Even if I modprobe it, the fans are still crazy.

At boot time I've the following error message :
/u3@0,f8000000/i2c@f8001000: Missing interrupt or address !

I've tried to compile the latest 2.6.12 kernel and I've got the same error and
problem.

Cheers

Note You need to log in before you can comment on or make changes to this bug.