Bug 1516699 - [Ganesha] : ganesha.log should be inside /var/log/ganesha.
Summary: [Ganesha] : ganesha.log should be inside /var/log/ganesha.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha
Version: rhgs-3.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.4.0
Assignee: Kaleb KEITHLEY
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1503137
TreeView+ depends on / blocked
 
Reported: 2017-11-23 09:54 UTC by Ambarish
Modified: 2018-09-20 06:40 UTC (History)
13 users (show)

Fixed In Version: nfs-ganesha-2.5.5-1
Doc Type: Bug Fix
Doc Text:
With Red Hat Gluster Storage 3.4, NFS-Ganesha log files have been moved to the /var/log/ganesha subdirectory.
Clone Of:
Environment:
Last Closed: 2018-09-04 06:53:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2610 None None None 2018-09-04 06:54:41 UTC

Description Ambarish 2017-11-23 09:54:44 UTC
Description of problem:
-----------------------

ganesha.log looks out of place inside /var/log.

Good to keep it inside /var/log/ganesha (just like ganesha-gfapi logs) for better usability and easy consumption.


Version-Release number of selected component (if applicable):
--------------------------------------------------------------

nfs-ganesha-gluster-2.5.4-1.el7rhgs.x86_64
glusterfs-ganesha-3.12.2-1.el7rhgs.x86_64


How reproducible:
-----------------

100%

Comment 2 Daniel Gryniewicz 2017-11-27 16:45:08 UTC
This is already the default upstream and on 2.5.  It was done by commit 58877b02576334e9f9b21b2dec881031db7db49c in April.

Comment 5 Ambarish 2018-03-01 08:52:21 UTC
Both logs inside /var/log/ganesha in 2.5.5-2 , Verified.

Comment 10 errata-xmlrpc 2018-09-04 06:53:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2610


Note You need to log in before you can comment on or make changes to this bug.