Bug 151677 - xscreensaver tries to fallback load screen hacks from directories in the user's path.
xscreensaver tries to fallback load screen hacks from directories in the user...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-03-21 12:56 EST by Maxwell Bottiger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 09:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxwell Bottiger 2005-03-21 12:56:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
When a screensaver starts I get an error message saying there is an exit status of 1.  The screen fades in and out just as it should, but doesn't actually display any screen savers.  In gnome, if I look at the screensaver panel under preferences it only lists one screensaver (ant) and does not display anything when I preview it.  Occationally I will get something that looks a bit like the help or man page for a screensaver.  Also, it will complain about a -root flag.  These error messages appear randomly.

I removed my .xscreensaver file to see if that improved the situation, but it has not.

Version-Release number of selected component (if applicable):
xscreensaver-base-4.18-19

How reproducible:
Always

Steps to Reproduce:
1. Allow screensaver to start, or access it thourgh the Screensaver Prefs box
2.
3.
  

Actual Results:  A blank screen, or (randomly) a blank screen with an Xscreensaver error message 1

Expected Results:  Screensavers

Additional info:

I haven't seen the error come up in a while, but I'll write it down when I see it.
Comment 1 Aaron Kurtz 2005-03-21 17:23:36 EST
xscreensaver-base doesn't have any screensavers other than a screen blanker.
xscreensaver-extras and -gl-extras have all of the various hacks. Unfortunately,
one of the hacks from -extras is "ant", so xscreensaver-base picks up ant the
java build tool from /usr/bin/ant, which of course has no idea what -root is or
why you want it to make pretty pictures.
Comment 2 Jeremy Katz 2005-04-27 19:28:05 EDT
Is this still occurring? 
Comment 3 Ray Strode [halfline] 2005-05-03 14:53:29 EDT
Should be fixed in xscreensaver-4.21-2
Comment 4 Jonathan Abbey 2005-08-17 18:03:22 EDT
Actually, this is still occurring with xscreensaver-4.21-4.. but only when
xscreensaver-extras is not installed.

Amusingly, this same bug has bitten the PostGreSQL folks, in reverse.  They've
had to teach their configure script not to try and build their Java sources
using the xscreensaver ant module.

Is Jamie still maintaining xscreensaver?  Perhaps someone should drop him a note
about this.. ;-)
Comment 5 Ray Strode [halfline] 2005-08-17 18:13:02 EDT
Hi Jonathan,

Yea, Jamie knows about this issue.  It's still broken for you?  What if you try
th e latest rawhide package?
Comment 6 Jonathan Abbey 2005-08-17 18:29:33 EDT
Doh, wish I had read your reply before emailing him.  Now he'll think I'm lamerz.

Anyway.  I went ahead and installed the xscreensaver-extras-4.21-4 rpm on my
Fedora Core 4 box, and that took care of the problem from my perspective.

I suppose it's just inserting /usr/libexec/xscreensaver into PATH before my
default PATH, and when the xscreensaver-extras aren't installed, it falls
through to finding ant elsewhere.

I actually have ant under /opt/bin, so a simple check to make sure the ant that
is found isn't under /usr/bin wouldn't catch my case, if that's what you're doing?
Comment 7 Amin Adatia 2005-10-11 18:41:42 EDT
Any clue where to actually get the 4.21-4 version?

amin adatia
amin@knowtech.ca
Comment 8 Maxwell Bottiger 2005-10-12 16:35:28 EDT
You can pick up the 4.21-4 rpms from the fedora 4 repository.

http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/

Has anyone thought about adding the extras and gl-extras packages to the normal
fedora install (ie when I pick off workstation or something in anaconda) as a
way to solve the confusion over this?  If someone hadn't explained to me that
the screensavers weren't in the xscreensaver-base package I wouldn't have sorted
this out. (Which I guess is obvious since I started this report.)
Comment 9 Jonathan Abbey 2005-10-12 17:41:12 EDT
They deliberately removed the screen savers to an extra package so that naive
Fedora users wouldn't have some of the surprising/possibly
offensive/non-functional screen savers being displayed.

Note You need to log in before you can comment on or make changes to this bug.