Bug 1517069 - number of heal pending entries not showing up in webadmin dashboard
Summary: number of heal pending entries not showing up in webadmin dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Shubhendu Tripathi
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 06:51 UTC by nchilaka
Modified: 2017-12-18 04:37 UTC (History)
9 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-11.el7rhgs.noarch tendrl-gluster-integration-1.5.4-6.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
dashboard not showing heal pending (135.31 KB, image/png)
2017-11-24 06:51 UTC, nchilaka
no flags Details
pending heal (76.90 KB, image/png)
2017-12-06 18:30 UTC, Shubhendu Tripathi
no flags Details
heal pending completed (73.75 KB, image/png)
2017-12-06 18:34 UTC, Shubhendu Tripathi
no flags Details
healing panel (159.84 KB, image/png)
2017-12-07 07:58 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description nchilaka 2017-11-24 06:51:21 UTC
Created attachment 1358495 [details]
dashboard not showing heal pending

Description of problem:
====================
Webadmin dashboard doesnt list the number of heal pending entries.
It does have number of splitbrains, healfailed, but the most important thing required is number of heals pending, which is missing

Version-Release number of selected component (if applicable):
======================================
[root@dhcp37-47 ~]# rpm -qa|egrep "tendrl|gluster|kernel"
kernel-headers-3.10.0-693.5.2.el7.x86_64
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
kernel-3.10.0-693.el7.x86_64
kernel-tools-libs-3.10.0-693.5.2.el7.x86_64
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
kernel-3.10.0-693.5.2.el7.x86_64
kernel-tools-3.10.0-693.5.2.el7.x86_64
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch


How reproducible:
==============
always

Steps to Reproduce:
1.create some heal pending on volume
2.dashbaord not showing up 


WAITED FOR MORE THAN 10 MINUTES


[root@dhcp35-14 ~]# gluster v heal arb info|grep ntries
Number of entries: -
Number of entries: 10001
Number of entries: 10001

Comment 7 Lubos Trilety 2017-12-06 14:39:53 UTC
Tested with:
tendrl-gluster-integration-1.5.4-8.el7rhgs.noarch

# gluster v heal volume_gamma_arbiter_2_plus_1x2 info | grep entries
Number of entries: 5034
Number of entries: -
Number of entries: 5034
Number of entries: 4979
Number of entries: -
Number of entries: 4979

There's still Pending Heal 0 on Grafana dashboard.

Comment 8 Shubhendu Tripathi 2017-12-06 18:30:47 UTC
Created attachment 1363847 [details]
pending heal

Comment 10 Shubhendu Tripathi 2017-12-06 18:34:16 UTC
Created attachment 1363860 [details]
heal pending completed

Comment 11 Lubos Trilety 2017-12-07 07:58:15 UTC
Created attachment 1364095 [details]
healing panel

no heal pending count and no split brain count

Comment 14 Lubos Trilety 2017-12-07 09:13:53 UTC
There was a miscomprehension on my side. For the number to be showing a heal process must start. With that in mind I was able to reproduce the BZ with success, hence moving it to VERIFIED.

Comment 16 errata-xmlrpc 2017-12-18 04:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.