Bug 1517088 - total list of bricks in brick status of volume dashboard is showing up after a very long time(30min)
Summary: total list of bricks in brick status of volume dashboard is showing up after ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 07:37 UTC by nchilaka
Modified: 2017-12-18 04:37 UTC (History)
5 users (show)

Fixed In Version: tendrl-ui-1.5.4-4.el7rhgs.noarch tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description nchilaka 2017-11-24 07:37:03 UTC
Description of problem:
=====================
I create a 2x(4+2) ec volume on 3 nodes, and even after 30min, it took more than 30min to show up the total list of bricks in brick status.
it showed only about 5(for first 10min) or 6(for next 20min) bricks for about 30min before it took to reflect all 12 bricks


Version-Release number of selected component (if applicable):
======================================
[root@dhcp37-47 ~]# rpm -qa|egrep "tendrl|gluster|kernel"
kernel-headers-3.10.0-693.5.2.el7.x86_64
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
kernel-3.10.0-693.el7.x86_64
kernel-tools-libs-3.10.0-693.5.2.el7.x86_64
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
kernel-3.10.0-693.5.2.el7.x86_64
kernel-tools-3.10.0-693.5.2.el7.x86_64
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch


How reproducible:
==============
always

Steps to Reproduce:
1.create an ec volume of about 12 or more bricks say 3x(4+2)
2.all bricks get discovered only after about 30min

Comment 3 Nishanth Thomas 2017-11-28 05:38:43 UTC
There is no fix required to be done in the code. This is basically an issue with sync intervals. So this issue won't be seen with latest builds with reduced default sync intervals, if run on the recommended hw configuration.

Comment 9 errata-xmlrpc 2017-12-18 04:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.