Bug 151710 - LOCATE_PATH is ignored if system SLOCATEDB is used
LOCATE_PATH is ignored if system SLOCATEDB is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: slocate (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 15:06 EST by Diab Jerius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.7-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-25 06:20:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diab Jerius 2005-03-21 15:06:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050105 Galeon/1.3.20 (Debian package 1.3.20-1)

Description of problem:
If a user specifies databases via the LOCATE_PATH environmental variable, they will be ignored if the system slocate db is used.  The problem is that the parse_decode_path() routine always overwrites the current path, rather than appending to it.  For example:

  env LOCATE_PATH=mydb locate foo

will ignore mydb.

This is fixed in the latest version of this package, which now seems to be the Debian version, as the author is a Debian developer.  Here's where I found it: 

http://packages.debian.org/unstable/source/slocate

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
% mkdir foo
% cp /etc/motd foo/MyMOTD
% slocate -U `pwd`/foo -o foo.db
% env LOCATE_PATH=foo.db locate MyMOTD
% locate -d foo.db MyMOTD
/data/pelf0/dj/tmp/buggy/foo/MyMOTD

  

Additional info:
Comment 1 Miloslav Trmač 2005-03-25 06:20:15 EST
slocate-2.7-17 in rawhide uses Debian slocate_2.7-4. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.