Bug 1517323 - lazbuild binary not working on Rawhide for arm
Summary: lazbuild binary not working on Rawhide for arm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lazarus
Version: 28
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joost van der Sluis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1485628
TreeView+ depends on / blocked
 
Reported: 2017-11-24 15:33 UTC by Richard Shaw
Modified: 2018-03-01 13:32 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-01 13:32:04 UTC


Attachments (Terms of Use)

Description Richard Shaw 2017-11-24 15:33:05 UTC
Description of problem:
I have not been able to build a new version of cqrlog due to the lazbuild binary on arm.

Version-Release number of selected component (if applicable):
lazarus.armv7hl 1.6.4-3.fc27


Actual results:
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.d8BmXn
+ umask 022
+ cd /builddir/build/BUILD
+ cd cqrlog-2.1.0
+ make -j4
lazbuild --ws=gtk2 --pcp=/tmp/.lazarus src/cqrlog.lpi
make: lazbuild: Command not found
make: *** [Makefile:9: cqrlog] Error 127
error: Bad exit status from /var/tmp/rpm-tmp.d8BmXn (%build)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.d8BmXn (%build)
Child return code was: 1


Expected results:
Package builds


Additional info:
https://koji.fedoraproject.org/koji/taskinfo?taskID=23341464

Comment 1 Richard Shaw 2017-12-11 21:48:58 UTC
Are there any plans to fix the fpc/lazarus stack on Fedora or should I retire my package?

Comment 2 Peter Hjalmarsson 2018-02-10 19:27:54 UTC
Intereseting, installing lazarus on my local arm7hl-machine (rpi3) and lazbuild is possible to invoke without problems, so the question is if the stack is broken and if that is the case where.

I will see if I can set up mock and make a test run.

Comment 3 Fedora End Of Life 2018-02-20 15:33:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 4 Joost van der Sluis 2018-02-28 21:50:46 UTC
I think that this problem has been solved with the latest update to fpc 3.0.4. (Actually the problem was not in fpc, but a packaging-error which is also solved in 3.0.4-1)

Can you retry?

Comment 5 Richard Shaw 2018-02-28 22:24:24 UTC
Yes, the lazbuild issue appears to be resolved but cqrlog still fails to build on arm for another reason...

https://kojipkgs.fedoraproject.org//work/tasks/5427/25375427/build.log

Comment 6 Richard Shaw 2018-03-01 13:32:04 UTC
ARM fix is upstream. I've applied the patch and am doing a scratch build now to verify it's fixed.


Note You need to log in before you can comment on or make changes to this bug.