Bug 151738 - Export to PDF results in large unprintable PDF file.
Export to PDF results in large unprintable PDF file.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 16:35 EST by Bob Gustafson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 07:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2005-03-21 16:35:32 EST
Description of problem:

I exported a letter to PDF format and then could not print the letter (PDF
Viewer, or Adobe Acrobat on another system)

I was desperate to get an email-able version of my letter, so I printed the
letter to a Postscript file and then used ps2pdf to convert it to a pdf document.

I was surprised that the export PDF file was 15 times larger than the ps -> pdf
document.

[user1@hoho2 ~]$ ls -l Digi-Data*
-rw-rw-r--  1 user1 user1 525506 Mar 21 13:47 Digi-Drive.export.pdf
-rw-r--r--  1 root  root   33672 Mar 21 14:05 Digi-Drive.pdf
-rw-rw-r--  1 user1 user1 921892 Mar 21 14:04 Digi-Drive.ps
-rw-rw-r--  1 user1 user1  14564 Mar 21 13:36 Digi-Drive.sxw
[user1@hoho2 ~]$

  This smaller PDF file seems to print out OK. I sent it.

Version-Release number of selected component (if applicable):

  OpenOffice 1.1.3 as in FC3 release-updates as of a few days ago.

How reproducible:

  Only tried once, but I seem to remember doing it once before with similar results.

Steps to Reproduce:

1. Write text document
2. Export as PDF
3. Try to print resulting PDF document using Adobe acrobat
  
Actual results:

 As above

Expected results:

  I expect that the 'export to PDF' document and the 'print to Postscript ->
ps2pdf' document will/would be exactly the same.

Additional info:

 Fedora Core 3 - with released updates.
Comment 1 Sitsofe Wheeler 2005-03-21 18:31:12 EST
I've just reproduced this using an OOo file consisting of no more than
This is a test

Here are the file sizes:
149939 test-ooo.pdf
3548   test-ps2pdf.pdf

By using pdffonts on both files it becomes clear what is happening. OOo embeds
fonts different to ps2pdf.

[x@x ~]$ pdffonts test-ooo.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
NimbusRomanNo9L-Regu                 Type 1       yes no  yes      9  0

[x@x ~]$ pdffonts test-ps2pdf.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
FHXUYG+NimbusRomanNo9L-Regu          Type 1C      yes yes no      10  0

From this we can see that whereas
OOo embedded the font as Type 1 unicode, ps2pdf embedded fonts using Type 1C
(Compact Font Format), only embedded a subset and did not use Unicode.

Both files were described by file as "PDF document, version 1.4".

I bet this has been discussed to death somewhere.
Comment 2 Sitsofe Wheeler 2005-03-21 18:33:26 EST
I forgot to mention that I selected "Optimise for screen" in the Select PDF
Options window.
Comment 3 Bob Gustafson 2005-03-21 23:01:39 EST
[root@hoho2 user1]# pdffonts Digi-Drive.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
NAEOAR+NimbusRomanNo9L-Regu          Type 1C      yes yes no      10  0
WFNOLO+NimbusRomNo9L-Medi            Type 1C      yes yes no      13  0
LCYGSG+NimbusRomNo9L-MediItal        Type 1C      yes yes no      16  0
[root@hoho2 user1]# pdffonts Digi-Drive.export.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
NimbusRomanNo9L-Regu                 Type 1       yes no  yes     18  0
NimbusRomNo9L-Medi                   Type 1       yes no  yes     26  0
NimbusRomNo9L-MediItal               Type 1       yes no  yes     31  0
NimbusRomanNo9L-Regu                 Type 1       yes no  yes     21  0
[root@hoho2 user1]#

OK, what does this mean? Why does the 'export' version not print on my
(Postscript) printer (HP 2100M)?
Comment 4 Sitsofe Wheeler 2005-03-22 14:25:41 EST
Woah there Bob! To keep your chances of a fix high stick to the one issue, one
bug rule. It looks like you have a prime candidate for another bug wrt to
exported OOo PD does not print on HP 2100M.

As to what it means, perhaps because your HP is a proper postscript printer it
is having the fonts downloaded to it and because the fonts are huge this is
taking forever. This is nothing but speculation though (it could be your printer
doesn't like unicode fonts or have nothing to do with fonts at all...).
Comment 5 Sitsofe Wheeler 2005-03-22 14:33:14 EST
(just to clarify, I think that "OOo produces larger than necessary PDF files" is
one bug and "PDF file takes forever to print on HP2100M" to be another bug).

Note You need to log in before you can comment on or make changes to this bug.