Bug 151748 - RFE: Eclipse initial window size larger than screen
RFE: Eclipse initial window size larger than screen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
: FutureFeature
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-21 17:57 EST by Anthony Green
Modified: 2011-12-12 16:35 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-24.fc6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-12 12:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-03-21 17:57:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
I have an 800x600 display and the initial Eclipse window is larger than the screen size, even though everything will comfortably fit inside the 800x600 display.

Perhaps this is really a window manager problem.  I just thought I'd start with Eclipse.


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M5.12

How reproducible:
Always

Steps to Reproduce:
1.Set display to 800x600
2.Start Eclipse for the first time.
3.
  

Additional info:
Comment 1 Andrew Overholt 2005-04-27 20:42:38 EDT
Jeremy, what makes you think this is an FC4Target-level bug?  There are much
more important Eclipse bugs that should be marked as FC4Target bugs.  Hmm,
perhaps you just marked all open fc4test{1,2} bugs as blockers.  That would make
sense, I guess :)
Comment 2 Andrew Overholt 2005-05-05 18:24:11 EDT
Are we sure this isn't an upstream bug?
Comment 3 Anthony Green 2006-01-25 20:30:41 EST
(In reply to comment #2)
> Are we sure this isn't an upstream bug?

No, but if we filed all bugs with their upstream projects wouldn't RH bugzilla
be empty? :-)

I'll make a note to try this again soon.

AG
Comment 4 Ben Konrath 2007-02-12 12:51:42 EST
I just tested this and it seems to be fixed in 3.2.1. Closing bug.
Comment 5 Andrew Overholt 2011-12-12 16:35:19 EST
I was reminded of this bug today.  It looks like it was decided that the minimum would be 1024x768 in April 2004:

  http://dev.eclipse.org/mhonarc/lists/platform-ui-dev/msg01814.html

This is what reminded me:

  http://dev.eclipse.org/mhonarc/lists/ui-best-practices-working-group/msg00529.html

Note You need to log in before you can comment on or make changes to this bug.