Bug 1517539 - qt5-qtwebkit FTBFS using cmake-3.10.0
Summary: qt5-qtwebkit FTBFS using cmake-3.10.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebkit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 15:15 UTC by Rex Dieter
Modified: 2017-11-26 17:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 16:53:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Rex Dieter 2017-11-26 15:15:02 UTC
Seems qt5-qtwebkit FTBFS recently, and I strongly suspect cmake-3.10.0 at the moment,
https://koji.fedoraproject.org/koji/taskinfo?taskID=23395505

I'd recommend holding off pushing this to stable releases, until this is more well-understood.

Comment 1 Björn 'besser82' Esser 2017-11-26 16:53:18 UTC
That was caused by a typo in the project's CMake config files and is *NOT* related to the new version 3.10.0…

See successful scratch build after applying a simple patch:
https://koji.fedoraproject.org/koji/taskinfo?taskID=23396739


```
Index: qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
===================================================================
--- qtwebkit-5.212.0-alpha2.orig/Source/WebKit/PlatformQt.cmake
+++ qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
@@ -786,6 +786,7 @@ if (COMPILER_IS_GCC_OR_CLANG)
     set_source_files_properties(
         qt/Api/qwebdatabase.cpp
         qt/Api/qwebelement.cpp
+        qt/Api/qwebfullscreenrequest.cpp
         qt/Api/qwebhistory.cpp
         qt/Api/qwebhistoryinterface.cpp
         qt/Api/qwebpluginfactory.cpp
@@ -795,7 +796,6 @@ if (COMPILER_IS_GCC_OR_CLANG)
 
         qt/WidgetApi/qgraphicswebview.cpp
         qt/WidgetApi/qwebframe.cpp
-        qt/WidgetApi/qwebfullscreenrequest.cpp
         qt/WidgetApi/qwebinspector.cpp
         qt/WidgetApi/qwebpage.cpp
         qt/WidgetApi/qwebview.cpp
```

Comment 2 Rex Dieter 2017-11-26 17:03:41 UTC
Triaging to proper component (qt5-qtwebkit), and thanks for the hand in fixing it quickly,

https://src.fedoraproject.org/rpms/qt5-qtwebkit/c/320889cc2a0f5866bfb6fc80c68824ccd3ad5db3?branch=master


Note You need to log in before you can comment on or make changes to this bug.