Bug 1517624 - [RFE] Need to automate the manual steps required to upgrade the client.
Summary: [RFE] Need to automate the manual steps required to upgrade the client.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Puppet
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
high with 3 votes vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks: 1547951
TreeView+ depends on / blocked
 
Reported: 2017-11-27 06:12 UTC by Giridhar
Modified: 2019-11-22 17:51 UTC (History)
29 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-22 17:51:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
new job template to update puppet and katello agent (1.09 KB, text/plain)
2018-06-24 21:40 UTC, Steven Mercurio
smercurio: review+
Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22400 Normal New Need to automate the manual steps required to upgrade the client. 2020-06-19 03:48:44 UTC
Red Hat Bugzilla 1547951 'high' 'CLOSED' 'Updating puppet agent from v3 to v4 doesnot migrate the configuration' 2019-12-03 16:55:01 UTC
Red Hat Knowledge Base (Solution) 3375371 None None None 2018-03-08 09:38:26 UTC

Internal Links: 1547951

Description Giridhar 2017-11-27 06:12:45 UTC
Description of problem:

 Need to automate the manual steps required to upgrade the client.  

Version-Release number of selected component (if applicable):

Satellite 6.3.0
Puppet: 4.10.7


How reproducible:

100%

Steps to Reproduce:
1.In order to upgrade the puppet client in satellite 6.3.0 below steps needs to be performed manually

2. Move the ssl directory
# mv /var/lib/puppet/ssl /etc/puppetlabs/puppet/ssl
 
3. Edit the /etc/puppetlabs/puppet.conf and set the master entries manually

# vi /etc/puppetlabs/puppet/puppet.conf



Actual results: The above steps need to be performed manually


Expected results:The above steps should be automated 


Additional info:

Either the package needs to be modified in such a way that a script is included to automate the manual steps or a package that automates the above steps and this should be installed as dependency to puppet-agent.

Comment 3 Ondřej Pražák 2018-01-24 09:58:23 UTC
Created redmine issue http://projects.theforeman.org/issues/22400 from this bug

Comment 5 Stephen Wadeley 2018-04-26 08:24:03 UTC
Hello


see comment https://bugzilla.redhat.com/show_bug.cgi?id=1547951#c17

Comment 7 Lukas Pramuk 2018-05-16 15:25:12 UTC
This reminds me of rejected RFE, see https://bugzilla.redhat.com/show_bug.cgi?id=1511505

So simply you can create your own script to be executed on remote hosts to migrate them on puppet4:
--8<------------------
subscription-manager repos --enable rhel-7-server-satellite-tools-6.3-puppet4-rpms
yum -y upgrade
cp -fp /etc/puppet/puppet.conf.rpmsave /etc/puppetlabs/puppet/puppet.conf
cp -rfp /var/lib/puppet/ssl /etc/puppetlabs/puppet
sed -i 's|vardir\s*=.*|vardir = /opt/puppetlabs/puppet/cache|' /etc/puppetlabs/puppet/puppet.conf
sed -i 's|logdir\s*=.*|logdir = /var/log/puppetlabs/puppet|' /etc/puppetlabs/puppet/puppet.conf
sed -i 's|rundir\s*=.*|rundir = /var/run/puppetlabs|' /etc/puppetlabs/puppet/puppet.conf
sed -i 's|ssldir\s*=.*|ssldir = /etc/puppetlabs/puppet/ssl|' /etc/puppetlabs/puppet/puppet.conf
service puppet restart
---8<------------------

Comment 8 Steven Mercurio 2018-06-24 21:40:55 UTC
Created attachment 1454206 [details]
new job template to update puppet and katello agent

I think that just adding a new template like this will be a good solution to this and make migrations easier.  It does both puppet 3 to 4 and katello at once but they can easily be extended to do things like update puppet only if enable-puppet4 is true, etc if needed.

Comment 9 Steven Mercurio 2018-06-24 21:42:51 UTC
I added a quick job template I created to handle my puppet/katello updates.  This is something that should be safe to have run on all hosts once a day until all the migrations were completed.

Comment 18 Bryan Kearney 2019-11-22 17:51:49 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.