Bug 151764 - Clock not adjusted when Daylight Saving ended
Clock not adjusted when Daylight Saving ended
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Petr Raszyk
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-03-21 22:30 EST by Michael McDonald
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-03 03:37:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael McDonald 2005-03-21 22:30:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
The computer was shut down prior at the time daylight-saving ended.  When the computer was started after the changeover, the clock (as displayed on the bottom RHS of the screen) had not been readjusted, ie not turned back an hour.

Interestingly, emails going out show +1300 prior to the changeover and +1200 after the changeover, so the end of daylight saving has been recognised, at least partially.  (Timezone is Pacific/Auckland)

Windows XP Pro was booted the following day, and it adjusted the clock - WITHOUT notifying me of the event.  After rebooting into Linux the clock displayed is at it ought.

Another issue that may or may not have any bearing is that currently under Linux, time synchronisation is failing.  There seems to be an issue with some of the libraries and SELinux, but I haven't tried to resolve that series of problems.  MySQL is another service that won't start.

The computer normally runs RH Core 3, but Windows XP is booted a few times per week for some tasks.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:
Comment 1 Michael McDonald 2005-03-22 00:57:38 EST
Reassignment to ntp noted.  That may be the key to the problem ... ntp (ntpd?)
is not starting ... startup log is not being saved either!

[michael@localhost ~]$ ps -el | grep -i nt
1 S     0     3     1  0  65 -10 -     0 -      ?        00:00:00 events/0
1 S     0  3773     1  0  76   0 -   522 -      ?        00:00:00 dhclient
1 S   500  5242     1  0  78   0 -   909 select ?        00:00:00 ssh-agent
[michael@localhost ~]$
Comment 2 Michael McDonald 2005-03-22 02:13:01 EST
Further exploration showed that reported bug 150930 was the situation I was
experiencing (ntpd and several other services not starting).

The solution suggested ( touch /.autorelabel ) seems to have fixed the problem
of the services not starting.

So, if ntpd not starting is the reason the clock was not reset, then the problem
has been solved.
Comment 3 Petr Raszyk 2005-11-03 03:37:49 EST
This is not a bug in 'ntpd'. I assume, the 'ntpd'
is not running. Try at the command prompt:
ps -ef|grep ntpd
I assume, the 'ntpd' is not installed in your OS.
Try at the command prompt: 
ls -lisa /usr/sbin/ntpd

Back to your issue:
Launch (at command prompt): system-config-date
then press 'Alt z' keys,
then press 'Alt s' keys.
This activate the checkbox 'System clock uses UTC'.
This helps.

Note You need to log in before you can comment on or make changes to this bug.